搜索-B

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
1、题意:给你一个国际象棋中的骑士,给你棋盘的大小,让你求骑士能否按照他的走法走遍所有的点,如果可以输出行走的路线,不行输出impossible.

2、思路:因为要按照字母大小输出,而如果骑士能够走遍所有的点,那么肯定能够到达A1,所以直接从A1开始走就行了,然后搜索即可.

3、代码:

#include<iostream>
#include<string.h>
using namespace std;
int dx[8] = {-1,1,-2,2,-2,2,-1,1};
int dy[8] = {-2,-2,-1,-1,1,1,2,2};
char zb[28]={'A','B','C','D','E','F','G','H','I','J','K','L','M','N','O','P','Q','R','S','T','U','V','W','X','Y','Z'};
int step[100][100];
int s[100][100];
int flag;
int n,m;
void dfs(int a,int b,int c)
{
step[c][0]=a;
step[c][1]=b;
int aa;
int bb;
if(c==n*m)
	{
	flag=1;
	return;
	}
for(int i=0;i<8;i++)
	{
	aa=a+dx[i];
	bb=b+dy[i];
	if(aa>=1&&aa<=n&&bb>=1&&bb<=m&&!s[aa][bb]&&!flag)
		{
		s[aa][bb]=1;
        dfs(aa,bb,c+1);
        s[aa][bb]=0;
		}
	}
}
int main()
{
int t,tt=0;
cin>>t;
while(t--)
	{
	tt++;
	cin>>n>>m;
	flag=0;
	memset(s,0,sizeof(s));
	s[1][1]=1;
	dfs(1,1,1);
	cout<<"Scenario #"<<tt<<":"<<endl;
	if(flag==0)
		cout<<"impossible"<<endl;
	else
		{
		for(int i=1;i<=n*m;i++)
			cout<<zb[step[i][1]-1]<<step[i][0];
		cout<<endl;
		}
	cout<<endl;
	}
return 0;
}
4、总结:注意每个答案后面要有一个空行.


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值