搜索-G

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

1、题意:给你人和牛的坐标,然后人可以向前或者向后移动一步,或者向前移动到当前坐标的两倍处,让你求最少需要移动几步.
2、思路:直接广搜即可.
3、代码:
#include<iostream>
#include<queue>
#include<string>
#include<string.h>
using namespace std;
int main()
{
int a,b,flag=0;
int t=1;
int tt=1;
int d,dd,ddd;
int ttt=1;
int i;
int x[200002];
memset(x,0,sizeof(x));
cin>>a>>b;
queue<long> q;
q.push(a);
if(a==b)
	cout<<0<<endl;
else
while(1)
	{
	tt=ttt;
	ttt=0;
	for(i=0;i<tt;i++)
		{
		d=q.front()+1;
		dd=q.front()-1;
		ddd=q.front()*2;
		if(d==b||dd==b||ddd==b)
			{
			flag=1;
			break;
			}
		if(d>=0&&d<=200002&&x[d]==0)
			{
			q.push(d);
			ttt++;
			x[d]=1;
			}
		if(dd>=0&&dd<=200002&&x[dd]==0)
			{
			q.push(dd);
			ttt++;
			x[dd]=1;
			}
		if(ddd>=0&&ddd<=200002&&x[ddd]==0)
			{
			q.push(ddd);
			ttt++;
			x[ddd]=1;
			}
		q.pop();
		}
	if(flag==1)
		{
		cout<<t<<endl;
		break;
		}
	t++;
	}
return 0;
}
4、总结:一定要注意每次搜索记得将每个点标记,说明这个点走过了,不然会超时...


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值