POJ-1655-Balancing Act

Balancing Act
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14877 Accepted: 6323

Description

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T.
For example, consider the tree:

Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two.

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number.

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output

1 2

Source

题意:和Godfather,Tree cutting一模一样,求删点后子树中点最多的点最少,输出点与值。

代码:

#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
int pp;
int n;
struct node
{
int a,b;
int to;
}mapp[40005];
int father[20005];
int ss[20005];
int dp[20005];
void build(int l,int r)
{
mapp[pp].a=l;
mapp[pp].b=r;
mapp[pp].to=father[l];
father[l]=pp++;
}
int dfs(int p,int next)
{
int i,j,vv;
ss[p]=1;
int s=0;
for(i=father[p];i!=-1;i=mapp[i].to)
    {
    vv=mapp[i].b;
    if(vv==next)
        continue;
    dfs(vv,p);
    ss[p]+=ss[vv];
    s=max(s,ss[vv]);
    }
dp[p]=max(s,n-ss[p]);
}
int main()
{
int i,t,a,b;
cin>>t;
while(t--)
    {
    cin>>n;
    pp=0;
    for(i=0;i<=n;i++)
        dp[i]=0,father[i]=-1;
    for(i=0;i<n-1;i++)
        {
        scanf("%d%d",&a,&b);
        build(a,b);
        build(b,a);
        }
    dfs(1,0);
    int s=1;
    for(i=2;i<=n;i++)
        if(dp[s]>dp[i])
            s=i;
    cout<<s<<" "<<dp[s]<<endl;
    }
return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值