第十五周周四总结

  这几天有点懈怠了。。。这几天做的看的这几道题感觉比之前题要难了。

  

Find the number of ways to tile an m*n rectangle with long dominoes -- 3*1 rectangles.

Each domino must be completely within the rectangle, dominoes must not overlap (of course, they may touch each other), each point of the rectangle must be covered.


Input

The input contains several cases. Each case stands two integers m and n (1 <= m <= 9, 1 <= n <= 30) in a single line. The input ends up with a case of m = n = 0.


<p< dd="">
Output

Output the number of ways to tile an m*n rectangle with long dominoes.


<p< dd="">
Sample Input

3 3
3 10
0 0

<p< dd="">
Sample Output

2
28
#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
int n,m,state[10],ss[20];
long long dp[32][20005];
void dfs(int p,int sstate,int now,int pp)
{
if(p==n)
    {
    dp[now+1][sstate]+=dp[now][pp];
    return;
    }
if(!ss[p])
    {
    if(p+3<=n&&!ss[p+2]&&!ss[p+1])
        dfs(p+3,sstate,now,pp);
    dfs(p+1,sstate+2*state[p],now,pp);
    }
else if(ss[p]==1)
        dfs(p+1,sstate,now,pp);
else
    dfs(p+1,sstate+state[p],now,pp);
}
int main()
{
state[0]=1;
for(int i=1;i<10;i++)
    state[i]=state[i-1]*3;
while(cin>>n>>m&&n+m)
    {
    if(n*m%3!=0)
        {
        cout<<0<<endl;
        continue;
        }
    memset(dp,0,sizeof(dp));
    dp[0][0]=1;
    for(int i=0;i<m;i++)
        for(int j=0;j<state[n];j++)
            if(dp[i][j])
                {
                memset(ss,0,sizeof(ss));
                if(j)
                    {
                    int jj=j;
                    int p=-1;
                    while(jj>0)
                        {
                        ss[++p]=jj%3;
                        jj/=3;
                        }
                    }
                dfs(0,0,i,j);
                }
    cout<<dp[m][0]<<endl;
    }
return 0;
}

刚适应了二进制一换成三进制有点不适应。记得这道题以前用的暴力模拟做的,然后超时,当时做题还没遇到过几次超时,haha。


Several friends are planning to take tourism during the next holiday. They have selected some places to visit. They have decided which place to start their tourism and in which order to visit these places. However, anyone can leave halfway during the tourism and will never back to the tourism again if he or she is not interested in the following places. And anyone can choose not to attend the tourism if he or she is not interested in any of the places.
Each place they visited will cost every person certain amount of money. And each person has a positive value for each place, representing his or her interest in this place. To make things more complicated, if two friends visited a place together, they will get a non negative bonus because they enjoyed each other’s companion. If more than two friends visited a place together, the total bonus will be the sum of each pair of friends’ bonuses.
Your task is to decide which people should take the tourism and when each of them should leave so that the sum of the interest plus the sum of the bonuses minus the total costs is the largest. If you can’t find a plan that have a result larger than 0, just tell them to STAY HOME.
Input
There are several cases. Each case starts with a line containing two numbers N and M ( 1<=N<=10, 1<=M<=10). N is the number of friends and M is the number of places. The next line will contain M integers Pi (1<=i<=M) , 1<=Pi<=1000, representing how much it costs for one person to visit the ith place. Then N line follows, and each line contains M integers Vij (1<=i<=N, 1<=j<=M), 1<=Vij<=1000, representing how much the ith person is interested in the jth place. Then N line follows, and each line contains N integers Bij (1<=i<=N, 1<=j<=N), 0<=Bij<=1000, Bij=0 if i=j, Bij=Bji.
A case starting with 0 0 indicates the end of input and you needn’t give an output.
Output
For each case, if you can arrange a plan lead to a positive result, output the result in one line, otherwise, output STAY HOME in one line.
Sample Input
2 1
10
15
5
0 5
5 0
3 2
30 50
24 48
40 70
35 20
0 4 1
4 0 5
1 5 0
2 2
100 100
50 50
50 50
0 20
20 0
0 0
Sample Output
5
41
STAY HOME
#include<iostream>
#include<string.h>
#include<stdio.h>
#include<vector>
#include<math.h>
using namespace std;
int n,m;
int money[11],fun[11][11],together[11][11];
int dp[1<<10][11],ss[1<<20][11];
vector<int>state[1<<10];
void solve()
{
int up=1<<n;
for(int i=0;i<up;i++)
    for(int j=0;j<up;j++)
        if((i&j)==j)
            state[i].push_back(j);
for(int i=0;i<up;i++)
    {
    int s=0,p=0;
    for(int j=0;j<n;j++)
        {
        if(i&(1<<j))
            {
            p++;
            for(int k=0;k<j;k++)
                if(i&(1<<k))
                    s+=together[j][k];
            }
        }
    for(int j=0;j<m;j++)
        {
        ss[i][j]=s;
        ss[i][j]-=p*money[j];
        for(int k=0;k<n;k++)
            if(i&(1<<k))
                ss[i][j]+=fun[k][j];
        }
    }
for(int i=0;i<up;i++)
    {
    for(int j=0;j<m;j++)
        dp[i][j]=-999999999;
    dp[i][0]=ss[i][0];
    }
for(int i=1;i<m;i++)
    for(int j=0;j<up;j++)
        for(int k=0;k<state[j].size();k++)
            dp[state[j][k]][i]=max(dp[state[j][k]][i],dp[j][i-1]+ss[state[j][k]][i]);
}
void csh()
{
for(int i=0;i<(1<<10);i++)
    state[i].clear();
}
int main()
{
while(cin>>n>>m&&n+m)
    {
    for(int i=0;i<m;i++)
        scanf("%d",&money[i]);
    for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
            scanf("%d",&fun[i][j]);
    for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
            scanf("%d",&together[i][j]);
    csh();
    solve();
    int ans=-999999999;
    int up=1<<n;
    for(int i=0;i<up;i++)
        ans=max(ans,dp[i][m-1]);
    if(ans<=0)
        cout<<"STAY HOME"<<endl;
    else
        cout<<ans<<endl;
    }
return 0;
}

这道题写起来感觉超麻烦,看着大神们的代码想了好久。。。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值