又做出一道题All in All

哎!很简单一道题,提交总是runtime error ,改了十几分钟,到最后终于该出来了,数组开的太小了抓狂抓狂抓狂

You have devised a new encryption technique which encodes a message by inserting between its charactersrandomly generated strings in a clever way. Because of pending patent issues we will not discuss indetail how the strings are generated and inserted into the original message. To validate your method,however, it is necessary to write a program that checks if the message is really encoded in the finalstring.Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can removecharacters from t such that the concatenation of the remaining characters is s.InputThe input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCIIcharacters separated by whitespace. Input is terminated by EOF.OutputFor each test case output, if s is a subsequence of t.Sample Inputsequence subsequenceperson compressionVERDI vivaVittorioEmanueleReDiItaliacaseDoesMatter CaseDoesMatterSample OutputYesNoYesNo

#include<stdio.h>
#include<string.h>
char s[100002],s1[100002];
int main()
{
	
	int i,j,len,len1,t=0;
	while(scanf("%s%s",s,s1)!=EOF)
	{
		t=0;i=0;
		len=strlen(s);
		len1=strlen(s1);
		for(j=0;j<len1;j++)
		{
			if(s1[j]==s[i]&&i<len)
			{
				t++;
				i++;
			//	continue;
			}
		}		
		if(t==len)
			printf("Yes\n");
		else 
			printf("No\n");
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kunsir_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值