hdu 4763Theme Section

Theme Section

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4235    Accepted Submission(s): 2033


Problem Description
It's time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a 'theme section'. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of 'EAEBE', where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?
 

Input
The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.
 

Output
There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.
 

Sample Input
      
      
5 xy abc aaa aaaaba aaxoaaaaa
 

Sample Output
      
      
0 0 1 1 2


#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int N = 1000000 + 10;
char s[N];
int next_[N];
void makeNext(char s[]){
	int k = 0;
	next_[0] = 0;
	int len = strlen(s);
	for(int i = 1; i < len; i++){
		while(k > 0 && s[i] != s[k]){
			k = next_[k - 1];
		}
		if(s[i] == s[k]) k++;
		next_[i] = k;
	}
}
int main(){
	int t;
	scanf("%d", &t);
	while(t--){
		//getchar();
		scanf("%s", s);
		makeNext(s);
		int len = strlen(s);
		int i = next_[len - 1];
		int ans=0;
		while(i > 0){
			int k = len - i - 1;
			while(next_[k] == 0 && k >= 2 * i - 1){
				k--;
			}
			if(next_[k] >= i){
				ans = i;
				break;
			}
			//i = next_[i - 1];
			//i = next_[k - 1];
			i--;
		}
		printf("%d\n", ans);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kunsir_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值