POJ - 3984 迷宫问题

迷宫问题
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 31583 Accepted: 18083

Description

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

AC代码:

#include<iostream>
#include<queue>
#include<cstring>
#include<vector>
using namespace std;
struct node{
    int x,y;
    int f;
};
int s[10][10],head,tail;
int Next[4][2]={{-1,0},{0,1},{1,0},{0,-1}};
bool vis[10][10];
struct node que[100];
void bfs(int stx,int sty){
    memset(vis,false,sizeof(vis));
    vis[stx][sty]=true;
    head=0,tail=0;
    bool flag=false;
    que[tail].x=stx;
    que[tail].y=sty;
    que[tail++].f=head;
    while(head<tail){
        for(int k=0;k<=3;k++){
            int tx=que[head].x+Next[k][0];
            int ty=que[head].y+Next[k][1];
            if(tx<0||ty<0||ty>4||tx>4) continue;
            if(!vis[tx][ty]&&s[tx][ty]==0){
                que[tail].x=tx;
                que[tail].y=ty;
                que[tail++].f=head;
                vis[tx][ty]=true;
            }
            if(tx==4&&ty==4){
                flag=true;
                break;
            }
        }
        if(flag) break;
        head++;
    }
}
void PrintPath(int k){
    if(k==0){
        cout<<"("<<que[0].x<<", "<<que[0].y<<")"<<endl;
        return;
    }
    PrintPath(que[k].f);
    cout<<"("<<que[k].x<<", "<<que[k].y<<")"<<endl;
}
int main(){
    for(int i=0;i<5;i++){
        for(int j=0;j<5;j++){
            cin>>s[i][j];
        }
    }
    bfs(0,0);
    PrintPath(tail-1);
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kunsir_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值