ZOJ 1914 Arctic Network

ZOJ 1914 Arctic Network

题目链接

Arctic Network

Time Limit: 2 Seconds Memory Limit: 65536 KB
The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.

Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.
Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13
213

题意:国防部想把北部前哨之间连接起来,在建立网络时,有两种技术:卫星频道和无线电收发器。卫星频道可以连接,不限制距离、;无线电限制距离,所有岗哨之间无线电型号相同,即最远通讯距离D相同。当然距离越远成本越高。找出可以连接所有岗哨,且花费最少的D;
分析:构建MST,距离最远的岗哨之间用卫星,距离近的用无线电
AC代码
#include <cmath>
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int N=1010;
struct node{
    int u,v,d;
}q[N*N];
int x[N],y[N],pre[N];
int S,P,cnt;
int distance(int i,int j){
    return (x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]);
}
void init(){
    for(int i=1;i<=P;i++){
        pre[i]=i;
    }
    cnt=0;
}
int Find(int x){
    if(x!=pre[x]) pre[x]=Find(pre[x]);
    return pre[x];
}
void join(int x,int y){
    int tx=Find(x);
    int ty=Find(y);
    if(tx!=ty){
        pre[ty]=tx;
    }
}
bool cmp(node a,node b){
    return a.d<b.d;
}
int Kru(){
    int cnt1=0,ans=0;
    sort(q,q+cnt,cmp);
    for(int i=0;i<cnt;i++){
        if(Find(q[i].u)!=Find(q[i].v)){
            join(q[i].u,q[i].v);
            cnt1++;
            if(cnt1==P-S){
                ans=q[i].d;
                break;
            }
        }
    }
    return ans;
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&S,&P);
        init();
        for(int i=1;i<=P;i++){
            scanf("%d%d",&x[i],&y[i]);
        }
        for(int i=1;i<=P;i++){
            for(int j=i+1;j<=P;j++){
                q[cnt].u=i;
                q[cnt].v=j;
                q[cnt++].d=distance(i,j);
            }
        }
        int ans=Kru();
        printf("%.2lf\n",sqrt((double)ans));
    }
    return 0;
}

posted on 2018-09-28 08:41 坤sir 阅读(...) 评论(...) 编辑 收藏

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
目标检测(Object Detection)是计算机视觉领域的一个核心问题,其主要任务是找出图像所有感兴趣的目标(物体),并确定它们的类别和位置。以下是对目标检测的详细阐述: 一、基本概念 目标检测的任务是解决“在哪里?是什么?”的问题,即定位出图像目标的位置并识别出目标的类别。由于各类物体具有不同的外观、形状和姿态,加上成像时光照、遮挡等因素的干扰,目标检测一直是计算机视觉领域最具挑战性的任务之一。 二、核心问题 目标检测涉及以下几个核心问题: 分类问题:判断图像的目标属于哪个类别。 定位问题:确定目标在图像的具体位置。 大小问题:目标可能具有不同的大小。 形状问题:目标可能具有不同的形状。 三、算法分类 基于深度学习的目标检测算法主要分为两大类: Two-stage算法:先进行区域生成(Region Proposal),生成有可能包含待检物体的预选框(Region Proposal),再通过卷积神经网络进行样本分类。常见的Two-stage算法包括R-CNN、Fast R-CNN、Faster R-CNN等。 One-stage算法:不用生成区域提议,直接在网络提取特征来预测物体分类和位置。常见的One-stage算法包括YOLO系列(YOLOv1、YOLOv2、YOLOv3、YOLOv4、YOLOv5等)、SSD和RetinaNet等。 四、算法原理 以YOLO系列为例,YOLO将目标检测视为回归问题,将输入图像一性划分为多个区域,直接在输出层预测边界框和类别概率。YOLO采用卷积网络来提取特征,使用全连接层来得到预测值。其网络结构通常包含多个卷积层和全连接层,通过卷积层提取图像特征,通过全连接层输出预测结果。 五、应用领域 目标检测技术已经广泛应用于各个领域,为人们的生活带来了极大的便利。以下是一些主要的应用领域: 安全监控:在商场、银行
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kunsir_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值