杭电2053

Problem Description

There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).

 

Input

Each test case contains only a number n ( 0< n<= 10^5) in a line.

 

Output

Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).

 

Sample Input

1

5

Sample Output

1

0

#include<iostream>
#include<string.h>
using namespace std;

int main()
{
	int a[100005];
	memset(a,0,sizeof(a));
	int n;
	while(cin>>n){
		int num = 0;
	for(int i=1;i<=n;i++){
		if(n%i==0){
			num++;
		}
	}
	if(num%2==0){
		cout<<"0"<<endl;
	}else{
		cout<<"1"<<endl;
	}
	}
	return 0;
 } 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值