Subsequence

点击打开链接

                                         Subsequence

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3
题解:像我这种英语特别差的,对于这种题时题意似懂非懂的,这题第一次我以为是排序,但后面百度了才知道,这题压根就不排序,就是最小子序列的和大于或等于S的值,一般方法是会超时的,但应该可以优化的,不过这题可以用二分的思想做,二分对于我这种渣渣来说是很难理解的,思想总是很简单,但是实践起来就不一样了,下面这个是我参考了网上的代码,写出来的。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<cstdlib>
using namespace std;
int num[100005],str[100005];
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int n,m,left,right,ans;
		scanf("%d%d",&n,&m);
		for(int i=1;i<=n;i++)
		scanf("%d",&num[i]);
		str[0]=0;
		for(int i=1;i<=n;i++)
		{
			str[i]=str[i-1]+num[i];//求出num前i个的和 
		}
		ans=n+1;
		for(int i=n;i>=1;i--)
		{
			int s1=str[i]-m;//总的和减去m的值 
			if(s1<0)//不满足条件的话,不进行下面的操作			 
			continue;
		    int L=0,R=i;//二分思想 
		    while(L<R)
		    {
		    	int M=(L+R)/2+1;//求出中点 
				if (str[M]<=s1) 
				L=M;
				else
				R=M-1; 
			}
			ans=min(ans,i-L); 
		}
		if(ans==n+1)
		printf("0\n");
		else
		printf("%d\n",ans);
		
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值