Oil Deposits(BFS模板题)

点击打开链接

                                   Oil Deposits

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 
Sample Output
0
1
2
2
题解:这题既可以用DFS也可以用BFS来做

下面是BFS的代码:

//BFS广度优先搜索用到队列的内容
//q.empty()               //判断队列是否为空,如果队列为空返回true,否则返回false    
//q.size()                //返回队列中元素的个数    
//q.pop()                 //删除队列首元素但不返回其值    
//q.front()               //返回队首元素的值,但不删除该元素    
//q.push()                //在队尾压入新元素    
//q.back()                //返回队列尾元素的值,但不删除该元素     
#include<cstdio>
#include<queue>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 1e2 + 10;//全局变量 
typedef long long LL;
char s[MAX][MAX];
int n,m,vis[MAX][MAX],ans;
int fx[8] = {0,0,-1,1,-1,1,-1,1},fy[8] = {-1,1,0,0,-1,-1,1,1};
struct node
{
    int x,y;
};
void bfs(int x,int y){
    vis[x][y] = 1;
    queue <node> q;//定义一个队列 
    node o,w;
    o.x = x,o.y = y;
    q.push(o);//在队列尾部添加新元素 
    while(!q.empty())//判断队列是否为空,只要队列不空就一直搜索 
	{
        o = q.front();//记录一下第一个元素的值 
        q.pop();//删除第一个元素   
        for(int i = 0; i < 8; i++){ // 8 个方向  
            int xx = o.x + fx[i],yy = o.y + fy[i];
            if(xx >= 0 && yy >= 0 && xx < n && yy < m && !vis[xx][yy] && s[xx][yy] == '@')
			{  // 判断是否出界, 是否已经搜索过, 是否为油田 
                vis[xx][yy] = 1;//搜索过的全部标记为1 
                w.x = xx,w.y = yy;
                q.push(w);
            }
        }
    }
}
int main()
{
    while(~scanf("%d %d",&n,&m),m){
        memset(vis,0,sizeof(vis));
        for(int i = 0; i < n; i++)
            scanf("%s",s[i]);
        ans = 0;
        for(int i = 0; i < n; i++)
            for(int j = 0; j < m; j++)
                if(!vis[i][j] && s[i][j] == '@')
                    ans++,bfs(i,j); // // 第一次搜到 + 1  
        printf("%d\n",ans);
    }
    return 0;
}

这里附上一个BFS的博客

点击打开链接






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值