2118 sdut

数据结构实验之链表三:链表的逆置
Time Limit: 1000MS Memory Limit: 65536KB
Submit Statistic
Problem Description

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。
Input

输入多个整数,以-1作为结束标志。
Output

输出逆置后的单链表数据。
Example Input

12 56 4 6 55 15 33 62 -1
Example Output

62 33 15 55 6 4 56 12
Hint

不得使用数组。
Author

感悟:这道题需要考虑指针p的使用,以及输入的变量a,a的值赋予。。。。即可解决
**

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node * next;
};
struct node *f1(int n)
{
    int i;
    struct node *head,*p,*t;
    head =(struct node *)malloc (sizeof(struct node));
    head->next =NULL;
    t=head;
    for(i=0; i<n; i++)
    {
        p=(struct node *)malloc(sizeof(struct node));
        scanf("%d ",&p->data);
        p->next =NULL;
        t ->next = p;
        t=p;
    }
    return head;
}
struct node * f2(struct node *head1,struct node *head2)
{
    struct node * p1,*p2,*t;
    p1=head1->next;
    p2=head2->next;
    head1->next=NULL;
    t=head1;
    head2->next=NULL;
    free(head2);
    while(p1&&p2)
    {
        if(p1->data<p2->data)
        {
            t->next =p1;
            t=p1;
            p1=p1->next;
        }
        else //if(p1->data>=p2->data)为什么这么做不对
        {
            t->next =p2;
            t=p2;
            p2=p2->next;
        }
        if(p1)
            t->next=p1;
        else
            t->next=p2;
    }
    return head1;
}
int main()
{
    int a;
    struct node *head,*p,*q;
    head =(struct node *)malloc (sizeof(struct node));
    head->next =NULL;


    while(scanf("%d ",&a)!=EOF)
    {
        if(a==-1)
            break;
        else

        {
            p=(struct node *)malloc(sizeof(struct node));
            p->data=a;
            p->next =head->next;
            head->next=p;
        }
    }
    q=head->next;
    while(q)
    {
        if(q->next!=NULL)
            printf("%d ",q->data);
        else
            printf("%d\n",q->data);
        q=q->next;
    }

    return 0;
}

**

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值