1053 Path of Equal Weight (30 分)

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

struct Node {
	int weight;
	vector<int> child;
}node[110];

bool cmp(int a, int b) {
	return node[a].weight > node[b].weight;
}

int n, m, s;
int path[110];

void DFS(int index, int numbNode, int sum) {
	if (sum > s) return ;
	if (sum == s) {
		if (node[index].child.size() != 0) return ;
		
		for (int i = 0; i < numbNode; i++) {
			printf("%d", node[path[i]].weight);
			if (i < numbNode - 1) printf(" ");
			else printf("\n");
		}
		
		return ;
	}
	
	for (int i = 0; i < node[index].child.size(); i++) {
		int child = node[index].child[i];
		
		path[numbNode] = child;
		
		DFS(child, numbNode + 1, sum + node[child].weight);
	}
	
	
}

int main() {
	scanf("%d %d %d", &n, &m, &s);
	for (int i = 0; i < n; i++) {
		scanf("%d", &node[i].weight);
	}
	
	for (int i = 0; i < m; i++) {
		int k, id;
		scanf("%d %d", &id, &k);
		for (int j = 0; j < k; j++) {
			int u;
			scanf("%d", &u);
			node[id].child.push_back(u);
		}
		
		sort(node[id].child.begin(), node[id].child.end(), cmp);
	}
	
	path[0] = 0;
	DFS(0, 1, node[0].weight);

	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值