Prime Ring Problem
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 61907 Accepted Submission(s): 26691
Total Submission(s): 61907 Accepted Submission(s): 26691
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
题解:dfs从1开始找,循环判断即可。
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <vector>
#include <set>
#include <map>
using namespace std;
int n,ans[21];
int vis[105];
int k=1;
int is_Prime(int p){//素数判断
int a=sqrt(p);
if(p==0||p==1)
return 0;
for(int i=2;i<=a;i++){
if(p%i==0) return 0;
}
return 1;
}
void dfs(int x){
if(k==n+1&&is_Prime(ans[n]+ans[1])){//如果已经找到n个数并且第n个与1的和是素数则足以构成环,输出。
for(int i=1;i<n;i++){
printf("%d ",ans[i]);
}
printf("%d\n",ans[n]);
}
for(int i=2;i<=n;i++){
if(!vis[i]&&is_Prime(x+i)){//判断是否已经在素数序列中并且是否能够和前一个数构成素数
vis[i]=1;
ans[k++]=i;
dfs(i);
vis[i]=0;//找其他数是否满足条件
k--;
}
}
}
int main()
{
int cnt=0;
while(~scanf("%d",&n)&&n){
k=1;
cnt++;//案例个数
printf("Case %d:\n",cnt);
memset(vis,0,sizeof vis);
ans[k++]=1;//从1开始
vis[1]=1;
dfs(1);//从1开始搜
printf("\n");
}
return 0;
}