POJ 3041Asteroids【最小点覆盖】

题目链接:http://poj.org/problem?id=3041

 

Asteroids

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 25572 Accepted: 13814

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X. 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

 

二分图知识点:转自:https://blog.csdn.net/huangshuai147/article/details/51087275

  • 定理1:最小点覆盖=最大匹配数
  • 定理2:最小边覆盖=顶点数-最小点覆盖(最大匹配数)
  • 题解:将每行x看成一个X节点,每列y看成一个Y节点,障碍的坐标x,y看成X到Y的一条边,构建出图后,就变成了求最少的点,使得这些点与所有的边相邻,即最小点覆盖问题。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <vector>
#include <set>
#include <map>
using namespace std;
const int maxn=505;
int n,k;
int cnt=0;
int vis[maxn];
int e[maxn][maxn];
int match[maxn];
int dfs(int u){
    for(int i=1;i<=n;i++){
        if(!vis[i]&&e[u][i]){
            vis[i]=1;
            if(!match[i]||dfs(match[i])){
                match[i]=u;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int r,c;
    while(cin>>n>>k){
        memset(e,0,sizeof e);
        memset(match,0,sizeof match);
        for(int i=0;i<k;i++){
            cin>>r>>c;
            e[r][c]=1;
        }
        for(int i=1;i<=n;i++){
            memset(vis,0,sizeof vis);
            if(dfs(i)){
                cnt++;
            }
        }
        cout<<cnt<<endl;
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值