容斥原理dfs

Co-prime

Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
 

Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 1015) and (1 <=N <= 109).
 

Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
 

Sample Input
  
  
2
1 10 2
3 15 5
 

Sample Output
  
  
Case #1: 5
Case #2: 10
Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.
      题意:求[a,b]中与n互素的数的个数
    
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<stack>
#include<queue>
#include<map>
#include<set>
#include<vector>
#include<math.h>
#include<algorithm>
#include<stack>
using namespace std;
typedef long long ll;
const int maxn=100010;
ll p[maxn];
int len;
void get_p(ll n)
{
    len=0;
    ll i;
    for(i=2;i<=sqrt(n);i++)
    {
        if(n%i==0)
            p[len++]=i;
        while(n%i==0)
            n/=i;
    }
    if(n>1)
        p[len++]=n;
}
ll dfs(int num,ll n)
{
    ll ans=0;
    for(int i=num;i<len;i++)
    {
        ans+=n/p[i]-dfs(i+1,n/p[i]);
    }
    return ans;
}
int main()
{
    ll a,b,n;
    int t,cas;
    scanf("%d",&t);
    cas=0;
    while(t--)
    {
        scanf("%lld%lld%lld",&a,&b,&n);
        get_p(n);//cout<<1<<endl;
        ll ans=(b-dfs(0,b))-(a-1-dfs(0,a-1));
        printf("Case #%d: ",++cas);
        printf("%lld\n",ans);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值