hdu 2838求逆序数开了两个数组

http://acm.hdu.edu.cn/showproblem.php?pid=2838

Cow Sorting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4387    Accepted Submission(s): 1580


 

Problem Description

Sherlock's N (1 ≤ N ≤ 100,000) cows are lined up to be milked in the evening. Each cow has a unique "grumpiness" level in the range 1...100,000. Since grumpy cows are more likely to damage Sherlock's milking equipment, Sherlock would like to reorder the cows in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes Sherlock a total of X + Y units of time to exchange two cows whose grumpiness levels are X and Y.

Please help Sherlock calculate the minimal time required to reorder the cows.

 

 

Input

Line 1: A single integer: N
Lines 2..N + 1: Each line contains a single integer: line i + 1 describes the grumpiness of cow i.

 

 

Output

Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.

 

 

Sample Input

 

3 2 3 1

 

 

Sample Output

 

7

Hint

Input Details Three cows are standing in line with respective grumpiness levels 2, 3, and 1. Output Details 2 3 1 : Initial order. 2 1 3 : After interchanging cows with grumpiness 3 and 1 (time=1+3=4). 1 2 3 : After interchanging cows with grumpiness 1 and 2 (time=2+1=3).

 

 

Source

2009 Multi-University Training Contest 3 - Host by WHU

 

 

Recommend

gaojie   |   We have carefully selected several similar problems for you:  3450 2227 3030 2642 1166 

 题意:和以前求逆序数的题意一样,不过这不是求总共多少个逆序数,而是求如a[i-1]>a[i]花费就是a[i-1]+a[i],问使整个序列上升有序最小的花费。以前是求得使整个序列上升有序最小的交换次数。这个也一样。

//#include<bits/stdc++.h>
//using namespace std;
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
typedef long long ll;
const int maxn=1000010;
ll n,c[3][maxn];
ll lowbit(ll x)
{
    return x&(-x);
}
ll query(ll flag,ll x)
{
    ll res=0;
    while(x)
    {
        res+=c[flag][x];
        x-=lowbit(x);
    }
    return res;
}
void add(ll flag,ll x,ll val)
{
    while(x<=n)
    {
        c[flag][x]+=val;
        x+=lowbit(x);
    }
}
ll a[maxn];
int main()
{
    ll tmp1,tmp2,ans,i;
    while(scanf("%lld",&n)==1&&n)
    {
        ll ans=0;
        memset(c,0,sizeof(c));
        for(i=1;i<=n;i++)
            scanf("%lld",&a[i]);
        for(i=n;i>=1;i--)
        {
            add(1,a[i],1);
            add(2,a[i],a[i]);
            tmp1=query(1,a[i]-1);
            tmp2=query(2,a[i]-1);
            ans+=tmp1*a[i]+tmp2;
        }
        printf("%lld\n",ans);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值