包装的线段树--HDU 2795 Billboard

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input

There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.

Sample Input

3 5 5 2 4 3 3 3

Sample Output

1 2 1 3 -1

Author

hhanger@zju

题目大意:一个h*w的公告牌,要在其上贴公告。

输入的是1*wiw值,这些是公告的尺寸

接下来要满足的条件有:1、尽量往上,同一高度尽量靠左。2、求每个广告所在的行数。没有合适的位置贴了则输出-1叶子节点只有min(n, h)个,n个广告,每个广告一行才n行,h再大往后也用不到了,不要被10^9吓到;然后把每行的空间存进树,每贴一条广告就删除相应的空间。此题对高度h建立线段树,每个节点储存的是这一行最大的空位。

#include <iostream>
#include <cstdio>
#include <cstring>
 
using namespace std;
 
struct node
{
    int l,r;
    int Max;//这段区间内有最多空位的那一行的空位长度
} s[200000*4];
 
void InitTree(int l,int r,int k,int w)
{
    s[k].l=l;
    s[k].r=r;
    s[k].Max=w;
    if (l==r)
        return ;
    int mid=(l+r)/2;
    InitTree(l,mid,2*k,w);
    InitTree(mid+1,r,2*k+1,w);
}
 
void UpdataTree(int ww,int k)
{
    if (s[k].l==s[k].r)
    {
        printf ("%d\n",s[k].l);
        s[k].Max-=ww;
        return ;
    }
    if (ww<=s[k*2].Max)
        UpdataTree(ww,k*2);
    else
        UpdataTree(ww,k*2+1);
    s[k].Max=s[k*2].Max>s[k*2+1].Max?s[k*2].Max:s[k*2+1].Max;
}
 
int main()
{
    int h,w,n;
    int ww;
    while (~scanf("%d%d%d",&h,&w,&n))
    {
        if (h>n)//h<=n,大了就没有意义了
            h=n;
        InitTree(1,h,1,w);
        for (int i=1; i<=n; i++)
        {
            scanf("%d",&ww);
            if (s[1].Max>=ww)
                UpdataTree(ww,1);
            else
                printf ("-1\n");
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
大学生参加学科竞赛有着诸多好处,不仅有助于个人综合素质的提升,还能为未来职业发展奠定良好基础。以下是一些分析: 首先,学科竞赛是提高专业知识和技能水平的有效途径。通过参与竞赛,学生不仅能够深入学习相关专业知识,还能够接触到最新的科研成果和技术发展趋势。这有助于拓展学生的学科视野,使其对专业领域有更深刻的理解。在竞赛过程中,学生通常需要解决实际问题,这锻炼了他们独立思考和解决问题的能力。 其次,学科竞赛培养了学生的团队合作精神。许多竞赛项目需要团队协作来完成,这促使学生学会有效地与他人合作、协调分工。在团队合作中,学生们能够学到如何有效沟通、共同制定目标和分工合作,这对于日后进入职场具有重要意义。 此外,学科竞赛是提高学生综合能力的一种途径。竞赛项目通常会涉及到理论知识、实际操作和创新思维等多个方面,要求参赛者具备全面的素质。在竞赛过程中,学生不仅需要展现自己的专业知识,还需要具备创新意识和解决问题的能力。这种全面的综合能力培养对于未来从事各类职业都具有积极作用。 此外,学科竞赛可以为学生提供展示自我、树立信心的机会。通过比赛的舞台,学生有机会展现自己在专业领域的优势,得到他人的认可和赞誉。这对于培养学生的自信心和自我价值感非常重要,有助于他们更加积极主动地投入学习和未来的职业生涯。 最后,学科竞赛对于个人职业发展具有积极的助推作用。在竞赛中脱颖而出的学生通常能够引起企业、研究机构等用人单位的关注。获得竞赛奖项不仅可以作为个人履历的亮点,还可以为进入理想的工作岗位提供有力的支持。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值