HDU 2717 Catch That Cow

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15499    Accepted Submission(s): 4650


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 
题目大意是说农夫John去抓逃跑的奶牛,可是他只有两种移动的方式:走路和传送。走路的话,如果当前位置是X,在一个单位时间内只能移动到X-1和X+1的地方。传送的话,如果当前位置是X,在一个单位时间内只能移动到2*X的地方。问John最少用多少时间能走到奶牛的位置(N是农夫的位置,K是奶牛的位置)

这道题一眼看去就是用广搜,用STL的队列实现,同时用一个book数组记录已经走过的点


#include<iostream>
#include<queue>
#include<cstdio>
#include<cstring>
using namespace std;
int n,k;
//这个数组一定要开到200000大,因为点*2的地方.....在这里被坑了.....
int book[200010];
struct Node{
	int x,time;
};
queue<Node> que;
void bfs(){
	while(!que.empty()){
		int pos,step;
		pos=que.front().x;
		step=que.front().time;
		que.pop();
		if(pos==k){
			cout<<step<<endl;
			return ;
		}
		if(pos>=1&&!book[pos-1]){
			book[pos-1]=1;
			Node a;
			a.x=pos-1;
			a.time=step+1;
			que.push(a);
		}
		if(pos<=k&&!book[pos+1]){
			book[pos+1]=1;
			Node a;
			a.x=pos+1;
			a.time=step+1;
			que.push(a);
		}
		if(pos<=k&&!book[pos*2]){
			book[pos*2]=1;
			Node a;
			a.x=pos*2;
			a.time=step+1;
			que.push(a);
		}
	}

}
int main(){
	while(~scanf("%d%d",&n,&k)){
		while(!que.empty()) que.pop();
		memset(book,0,sizeof(book));
		Node start;
		start.x=n;
		start.time=0;
		book[n]=1;
		que.push(start);
		bfs();
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值