ZOJ 3713 In 7-bit

In 7-bit

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Very often, especially in programming contests, we treat a sequence of non-whitespace characters as a string. But sometimes, a string may contain whitespace characters or even be empty. We can have such strings quoted and escaped to handle these cases. However, a different approach is putting the length of the string before it. As most strings are short in practice, it would be a waste of space to encode the length as a 64-bit unsigned integer or add a extra separator between the length and the string. That's why a 7-bit encoded integer is introduced here.

To store the string length by 7-bit encoding, we should regard the length as a binary integer. It should be written out by seven bits at a time, starting with the seven least-significant (i.e. 7 rightmost) bits. The highest (i.e. leftmost) bit of a byte indicates whether there are more bytes to be written after this one. If the integer fits in seven bits, it takes only one byte of space. If the integer does not fit in seven bits, the highest bit is set to 1 on the first byte and written out. The integer is then shifted by seven bits and the next byte is written. This process is repeated until the entire integer has been written.

With the help of 7-bit encoded integer, we can store each string as a length-prefixed string by concatenating its 7-bit encoded length and its raw content (i.e. the original string).

Input

There are multiple test cases. The first line of input is an integer T indicating the number of test cases.

Each test case is simply a string in a single line with at most 3000000 characters.

Output

For each test case, output the corresponding length-prefixed string in uppercase hexadecimal. See sample for more details.

Sample Input
3
42
yukkuri shiteitte ne!!!
https://en.wikipedia.org/wiki/Answer_to_Life,_the_Universe,_and_Everything#Answer_to_the_Ultimate_Question_of_Life.2C_the_Universe_and_Everything_.2842.29
Sample Output
023432
1779756B6B75726920736869746569747465206E65212121
9A0168747470733A2F2F656E2E77696B6970656469612E6F72672F77696B692F416E737765725F746F5F4C6966652C5F7468655F556E6976657273652C5F616E645F45766572797468696E6723416E737765725F746F5F7468655F556C74696D6174655F5175657374696F6E5F6F665F4C6966652E32435F7468655F556E6976657273655F616E645F45766572797468696E675F2E323834322E3239

Author:  WU, Zejun
Contest:  The 10th Zhejiang Provincial Collegiate Programming Contest

题目大意:给你一个字符串,将他的长度以二进制的形式表示出来,取后7位,如果取了后7位以后剩下的还有1,就在后7位的前面补上一个一,然后一直重复 直到前面没有1为止,将结果以十六进制输出,然后将字符串的每个字符以十六进制输出。

10000000是128,所以我们将长度对128取余就得到二进制的后七位数字,再除于128就可判断剩下的二进制数的是否有1,

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char str[3000010];
int main(){
	int test;
	scanf("%d",&test);
	getchar();
	while(test--){
		gets(str);
		int len=strlen(str);
		//cout<<"-----"<<len<<endl;
		if(!len){
			printf("00");
		}
		int tmp=len;
		while(tmp){
			int res=tmp%128;
			tmp/=128;
			if(tmp) res+=128;
			printf("%02X",res);
		}
		//cout<<endl;
		for(int i=0;i<len;i++){
			//cout<<"****"<<str[i]<<endl;
			printf("%02X",str[i]);
		}
		cout<<endl;
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值