Aizu ALDS1_7_A Rooted Trees

Tree - Rooted Trees

Time Limit : 2 sec, Memory Limit : 65536 KB 
Japanese version is here

Rooted Trees

A graph G = (VE) is a data structure where V is a finite set of vertices and E is a binary relation on Vrepresented by a set of edges. Fig. 1 illustrates an example of a graph (or graphs).


Fig. 1

A free tree is a connnected, acyclic, undirected graph. A rooted tree is a free tree in which one of the vertices is distinguished from the others. A vertex of a rooted tree is called "node."

Your task is to write a program which reports the following information for each node u of a given rooted tree T:

  • node ID of u
  • parent of u
  • depth of u
  • node type (root, internal node or leaf)
  • a list of chidlren of u

If the last edge on the path from the root r of a tree T to a node x is (px), then p is the parent of x, and x is a child of p. The root is the only node in T with no parent.

A node with no children is an external node or leaf. A nonleaf node is an internal node

The number of children of a node x in a rooted tree T is called the degree of x.

The length of the path from the root r to a node x is the depth of x in T.

Here, the given tree consists of n nodes and evey node has a unique ID from 0 to n-1.

Fig. 2 shows an example of rooted trees where ID of each node is indicated by a number in a circle (node). The example corresponds to the first sample input.


Fig. 2

Input

The first line of the input includes an integer n, the number of nodes of the tree.

In the next n lines, the information of each node u is given in the following format:

id k c1 c2 ... ck

where id is the node ID of uk is the degree of uc1 ... ck are node IDs of 1st, ... kth child of u. If the node does not have a child, the k is 0.

Output

Print the information of each node in the following format ordered by IDs:

node idparent = p , depth = dtype, [c1...ck]

p is ID of its parent. If the node does not have a parent, print -1.

d is depth of the node.

type is a type of nodes represented by a string (rootinternal node or leaf). If the root can be considered as a leaf or an internal node, print root.

c1...ck is the list of children as a ordered tree.

Please follow the format presented in a sample output below.

Constraints

  • 1 ≤ n ≤ 100000

Sample Input 1

13
0 3 1 4 10
1 2 2 3
2 0
3 0
4 3 5 6 7
5 0
6 0
7 2 8 9
8 0
9 0
10 2 11 12
11 0
12 0

Sample Output 1

node 0: parent = -1, depth = 0, root, [1, 4, 10]
node 1: parent = 0, depth = 1, internal node, [2, 3]
node 2: parent = 1, depth = 2, leaf, []
node 3: parent = 1, depth = 2, leaf, []
node 4: parent = 0, depth = 1, internal node, [5, 6, 7]
node 5: parent = 4, depth = 2, leaf, []
node 6: parent = 4, depth = 2, leaf, []
node 7: parent = 4, depth = 2, internal node, [8, 9]
node 8: parent = 7, depth = 3, leaf, []
node 9: parent = 7, depth = 3, leaf, []
node 10: parent = 0, depth = 1, internal node, [11, 12]
node 11: parent = 10, depth = 2, leaf, []
node 12: parent = 10, depth = 2, leaf, []

Sample Input 2

4
1 3 3 2 0
0 0
3 0
2 0

Sample Output 2

node 0: parent = 1, depth = 1, leaf, []
node 1: parent = -1, depth = 0, root, [3, 2, 0]
node 2: parent = 1, depth = 1, leaf, []
node 3: parent = 1, depth = 1, leaf, []

Note

You can use a left-child, right-sibling representation to implement a tree which has the following data:

  • the parent of u
  • the leftmost child of u
  • the immediate right sibling of u

Reference

Introduction to Algorithms, Thomas H. Cormen, Charles E. Leiserson, Ronald L. Rivest, and Clifford Stein. The MIT Press.


 
题目大意:给你一个有根树的各个信息,输出它的父亲,深度,是什么性质的节点,子节点列表

用左子右兄弟表示法

#include<iostream>
#include<cstdio>
using namespace std;
const int maxn=1e5+7;
#define NIL -1
struct Node{
	int parent;
	int left;
	int right;
}tree[maxn];
int n;
int Depth[maxn];
//对所有节点初始化 
void init(){
	for(int i=0;i<n;i++){
		tree[i].parent=tree[i].left=tree[i].right=NIL;
	}
}
void calc_depth(int root,int depth){
	Depth[root]=depth;
	//先将兄弟节点的度数计算出来 
	if(tree[root].right!=NIL) calc_depth(tree[root].right,depth);
	//再递归子节点 
	if(tree[root].left!=NIL) calc_depth(tree[root].left,depth+1);
}
void print(int node){
	printf("node %d: parent = %d, depth = %d, ",node,tree[node].parent,Depth[node]);
	if(tree[node].parent==NIL) printf("root, ");
	else if(tree[node].left==NIL) printf("leaf, ");
	else printf("internal node, ");
	putchar('[');
	for(int i=0,tmp=tree[node].left;tmp!=NIL;i++,tmp=tree[tmp].right){
		if(i) printf(", ");
		printf("%d",tmp);
	}
	printf("]\n");
}
int main(){
	cin>>n;
	init();
	for(int i=0;i<n;i++){
		int node_index,a,bro;
		//输入节点下标和度数 
		cin>>node_index>>a;
		for(int j=0;j<a;j++){
			int node;
			cin>>node;
			//将最左边的节点放在left处 
			if(j==0) tree[node_index].left=node;
			//从子节点最左边的节点开始,剩下的每一个节点都是最左侧子节点的兄弟,放在right 
			else tree[bro].right=node;
			bro=node;
			//他们的父节点都是node_index 
			tree[node].parent=node_index;
		}
	}
	int root;
	//找出根节点 
	for(int i=0;i<n;i++){
		if(tree[i].parent==NIL){
			root=i;
		}
	}
	calc_depth(root,0);
	for(int i=0;i<n;i++){
		print(i);
	}
}


以前都是写二叉树,写起来只用考虑两个节点,第一次写这种,有点奇妙~

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值