HDU 5626 Clarke and points

Clarke and points

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 480    Accepted Submission(s): 337


Problem Description
Clarke is a patient with multiple personality disorder. One day he turned into a learner of geometric. 
He did a research on a interesting distance called Manhattan Distance. The Manhattan Distance between point  A(xA,yA)  and point  B(xB,yB)  is  |xAxB|+|yAyB|
Now he wants to find the maximum distance between two points of  n  points.
 

Input
The first line contains a integer  T(1T5) , the number of test case. 
For each test case, a line followed, contains two integers  n,seed(2n1000000,1seed109) , denotes the number of points and a random seed. 
The coordinate of each point is generated by the followed code. 

```
long long seed;
inline long long rand(long long l, long long r) {
  static long long mo=1e9+7, g=78125;
  return l+((seed*=g)%=mo)%(r-l+1);
}

// ...

cin >> n >> seed;
for (int i = 0; i < n; i++)
  x[i] = rand(-1000000000, 1000000000),
  y[i] = rand(-1000000000, 1000000000);
```
 

Output
For each test case, print a line with an integer represented the maximum distance.
 

Sample Input
  
  
2 3 233 5 332
 

Sample Output
  
  
1557439953 1423870062
 

Source
 
题目大意:给你几个点,要你求出这几个点中最大的曼哈顿距离(也就是题目的公式)

首先将公式写出来就能发现,无非就是两个加起来互相减和两个减互相减
所以维护两个加的最大最小和两个减的最大最小就可以了
#include<iostream>
using namespace std;
typedef long long ll;
ll seed;
inline ll rand(ll l, ll r){
	static ll mo=1e9+7,g=78125;
	return l+((seed*=g)%=mo)%(r-l+1);
}
ll ldj(ll n){
	if(n<0) return -n;
	else return n;
}
int main(){
	int test;
	cin>>test;
	while(test--){
		int n;
		cin>>n>>seed;
		ll x,y;
		ll maxx=-0x3f3f3f3f,maxy=-0x3f3f3f3f;
		ll minx=0x3f3f3f3f,miny=0x3f3f3f3f;
		for(int i=0;i<n;i++){
			x=rand(-1000000000,1000000000); 
			y=rand(-1000000000,1000000000); 
			maxx=max(maxx,x+y);
			maxy=max(maxy,x-y);
			minx=min(minx,x+y);
			miny=min(miny,x-y);
		}
		cout<<max((maxx-minx),(maxy-miny))<<endl;
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值