HDU - 1213

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5
Sample Output
2

4

题意:一个人邀请他的朋友来参见宴会,但是他们的同学不喜欢和陌生人坐在一起,但是如果A认识B,B认识C,那么也认为A和C认识,判断要给他们朋友准备几桌。

题目很简单,直接套用并查集模板就行,代码如下。

#include <bits/stdc++.h>
using namespace std;
const int maxn = 2000;
int fa[maxn], a[maxn];
int getf(int x)  // 找父亲
{
    if(x == fa[x]) return x;
    return fa[x] = getf(fa[x]);
}
void init() //初始化
{
    for(int i = 1; i < maxn; i++)
        fa[i] = i;
    memset(a, 0, sizeof(a));
}
void Union(int x,int y) // 合并他们的父亲
{
    x = getf(x);
    y = getf(y);
    if(x == y)
        return;
    fa[x] = y;

}
void read(int n, int m) // 读取数据
{
    int f1, f2;
    for(int i = 1; i <= m; i++)
    {
        cin >> f1 >> f2;
        Union(f1, f2);
    }

}
int main()
{
    int T;
    cin >> T;
    while(T--)
    {
        init();
        int n, m;
        cin >> n >> m;
        read(n, m);
        int ans = 0;
        for(int i = 1; i <= n; i++)
        {
            int father = getf(i);
            if(a[father] == 0)  // 判断父节点时候被计算过, 如果没算过,就加一,然后标记一下
            {
                ans++;
                a[father] = 1;
            }
        }
        cout << ans << endl;

    }
    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值