PAT-A 1002 A+B for Polynomials (25 分)

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

思路:

使用一个长度至少为1001的double型数组保存a,a[i]表示指数为i的项的系数。

不考虑相加后系数大于10的情况,输出时不考虑四舍五入。

在输入b的指数和对应的系数时,直接将其加和到a中。

#include <cstdio>
#include <vector>

using namespace std;

int main()
{
    //a[i]保存指数i的系数
    double a[1005] = {0};

    int k;
    int exp;//保存输入的指数
    double coef;//保存输入的系数

    scanf("%d", &k);
    for(int i = 0; i < k; i++)
    {
        scanf("%d %lf", &exp, &coef);
        a[exp] += coef;
    }

    scanf("%d", &k);
    for(int i = 0; i < k; i++)
    {
        scanf("%d %lf", &exp, &coef);
        a[exp] += coef;
    }

    vector<int> index;//保存系数不为0的指数
    for(int i = 1001; i >= 0; i--)
        if(a[i] != 0)
            index.push_back(i);

    printf("%d", index.size());
    for(int i = 0; i < index.size(); i++)
        printf(" %d %.1f", index[i], a[index[i]]);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值