PAT-A 1048 Find Coins (25 分)

1048 Find Coins (25 分)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10​5​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10​5​​, the total number of coins) and M (≤10​3​​, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V​1​​ and V​2​​ (separated by a space) such that V​1​​+V​2​​=M and V​1​​≤V​2​​. If such a solution is not unique, output the one with the smallest V​1​​. If there is no solution, output No Solution instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

思路:两点法。将所有面额从小到大排序,设置两个指针,分别指向第一张钱和最后一张钱。如果这两个面额的和大于给定面额,将指向最后一张钱的指针向前移动一个位置,通过减少大面额的方法减少总面额;如果这两个面额的和小于给定面额,将指向第一张钱的指针向后移动一个位置,通过增加小面额的方法增加总面额。如果这两个面额的和等于给定面额,刚好找到题目要求的小面额最小的情况,输出两个面额,退出程序即可。如果两个指针相等时还没有找到合适的面额,那么不存在符合条件的解。

#include <bits/stdc++.h>

using namespace std;

int all[100005];
int main()
{
    int n, m;
    scanf("%d %d", &n, &m);

    for(int i = 0; i < n; i++)
        scanf("%d", all + i);
    sort(all, all + n);//将所有面额按照从小到大排序

    int head = 0;//指示小面额
    int tail = n - 1;//指示大面额
    while(head < tail)
    {
        if(all[head] + all[tail] == m)
        {   //找到可以支付的面额
            printf("%d %d", all[head], all[tail]);
            return 0;
        }
        else if(all[head] + all[tail] < m)
            head++;//当前两端面额相加过小,增大小面额
        else
            tail--;//当前两端面额相加过大,减小大面额
    }
    printf("No Solution");
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值