PAT-A 1070 Mooncake (25 分) / PAT-B 1020 月饼(25分)

60 篇文章 0 订阅

1070 Mooncake (25 分)

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45

分析:

  1. 题目中给出的价格是总价格,月饼的库存量也可能是浮点数(题目只说是正数)。
  2. 将所有的月饼按照单价从高到低排序,然后逐个遍历月饼,比较月饼库存和市场需求,对总利润和市场需求进行更新即可。
#include <bits/stdc++.h>

using namespace std;

typedef struct cake
{
    double amount;
    double price;//总价
    double single;//每千吨单价
}cakes;

cakes cake[10010];

bool cmp(cakes a, cakes b)
{   //按照单递减排序
    return a.single > b.single;
}
int main()
{
    int n, d;
    scanf("%d%d", &n, &d);
    for(int i = 0; i < n; i++)
        scanf("%lf", &cake[i].amount);
    for(int i = 0; i < n; i++)
    {
        scanf("%lf", &cake[i].price);
        cake[i].single = cake[i].price / cake[i].amount;//计算月饼单价

    }
    sort(cake, cake + n, cmp);//按照单价递减进行排序

    double profit = 0;//总利润
    for(int i = 0; i < n; i++)//从单价最高的月饼开始遍历
    {
        if(cake[i].amount <= d)
        {   //该月饼总量小于等于市场需求
            profit += cake[i].price;
            d -= cake[i].amount;
        }
        else
        {   //该月饼总量大于市场需求
            profit += cake[i].price / cake[i].amount * d;
            d = 0;
        }
        if(0 == d)
            break;
    }
    printf("%.2f", profit);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值