Friend-Graph (暴力)

5 篇文章 0 订阅



Problem Description
It is well known that small groups are not conducive of the development of a team. Therefore, there shouldn’t be any small groups in a good team.
In a team with n members,if there are three or more members are not friends with each other or there are three or more members who are friends with each other. The team meeting the above conditions can be called a bad team.Otherwise,the team is a good team.
A company is going to make an assessment of each team in this company. We have known the team with n members and all the friend relationship among these n individuals. Please judge whether it is a good team.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.(T<=15)
The first line od each case should contain one integers n, representing the number of people of the team.( n3000 )

Then there are n-1 rows. The  i th row should contain n-i numbers, in which number  aij  represents the relationship between member i and member j+i. 0 means these two individuals are not friends. 1 means these two individuals are friends.
 

Output
Please output ”Great Team!” if this team is a good team, otherwise please output “Bad Team!”.
 

Sample Input
  
  
1 4 1 1 0 0 0 1
 

Sample Output
  
  
Great Team!


题意:判断 队伍是 Great Team!,还是 Bad Team!

           有 T 组数据; 每组数据输入 N ,接着是N-1行,第 i 行有 N-i 个数(只能为1 或者0 ),如果为1,说明第 i 个人与 第 i+j 个人是朋友,如果是 0 ,则不是朋友,当该队伍中有三个或三个以上的人互不为朋友或者互为朋友,则这个队伍是 Bad Team!,否则是 Great Team!;

题解:

            设立一个a[3000+5][3000+5] 的数组,如果第 i 个人与第 j 个人是朋友,则 a[3000+5][3000+5] =1;否则是 a[3000+5][3000+5] =0;接着三个循环判断是不是互为朋友就行了(注意这里的数组必须用作 bool,否则会内存超限,这个地方坑死了)


#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<iomanip>
using namespace std;
bool a[3000+5][3000+5];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        int n;
        scanf("%d",&n);
        memset(a,0,sizeof(a));
        for(int i=0;i<n;i++){
            for(int j=i+1;j<n;j++){
                int t;
                scanf("%d",&t);
                a[i][j]=t; a[j][i]=t;
            }
        }
        int flag1=0,flag2=0;
        for(int i=0;i<n;i++){
            for(int j=i+1;j<n;j++){
                for(int k=j+1;k<n;k++){
                    if(a[i][j]&&a[j][k]&&a[i][k]){
                        flag1=1; break;
                    }
                    if(a[i][j]==0&&a[i][k]==0&&a[j][k]==0){
                        flag2=1; break;
                    }
                }
                if(flag1||flag2) break;
            }
            if(flag1||flag2) break;
        }
        if(flag1||flag2) printf("Bad Team!\n");
        else printf("Great Team!\n");
    }
    return 0;
}







  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值