*搜索(剪剪剪枝)POJ - 1011 Sticks

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.
Input
The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.
Output
The output should contains the smallest possible length of original sticks, one per line.
Sample Input
9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0
Sample Output
6
5


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#define maxn 70
#define INF 0x3f3f3f3f
using namespace std;
bool vis[maxn];
int n;
int a[maxn];
int len;
bool cmp(int x,int y)
{
    return x>y;
}
bool dfs(int ans,int x)
{
    if(ans==0)
    {
        return 1; //所有的都被分配
    }
    if(x==0) x=len;
    for(int i=0; i<n; i++)
    {
        if(vis[i]||a[i]>x) continue;  //a[i]被用或者a[i]长度大于所需长度
        vis[i]=1;
        if(dfs(ans-1,x-a[i])) return true; //存放成功返回上一层
        vis[i]=0;
        if(x==len||x==a[i]) return false; //长度足够但不能被存满而返回到原是长度或a[i]
        while(a[i]==a[i+1])i++; //重复元素不搜索
    }
    return false;
}
int main()
{
    while(scanf("%d",&n)&&n)
    {
        int sum=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        sort(a,a+n,cmp);
        int i;
        for(i=a[0]; i<=sum/2; i++)
        {
            if(sum%i) continue;
            memset(vis,0,sizeof(vis));
            len=i;
            if(dfs(n,i))
            {
                printf("%d\n",i);
                break;
            }
        }
        if(i>sum/2) printf("%d\n",sum);
    }
    return 0;

}

怪不得网上代码都差不多,自能说要剪枝的地方太多,少了那个又不行,错了N次,照个学长的代码看着改都不行,我会常来看你的

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值