poj-2398 Toy Storage (排序+叉积)

Toy Storage

 POJ - 2398 

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore. 
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top: 


We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard. 

A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1

题目大意:有一个玩具盒,用n块板子隔出来了n+1个格子,现在有m个玩具随机的放在格子里,告诉你板子的位置和玩具的具体坐标,让你按照玩具数目从小到大输出有该玩具个数的格子数目。

题解:先对板子和玩具的位置进行一个从前往后的排序,然后依次从前往后判断每个玩具与板子的位置关系,也就是点与直线的位置关系,利用向量的叉积,求解就行。

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
using namespace std;
const int maxn = 5005;
struct no{  //记录板子的位置
    int up;
    int down;
}broad[maxn];

struct dot{   //记录玩具的位置
    int x;
    int y;
}node[maxn];

bool cmp1(no a1, no a2){   //对板子进行排序的方法
    return (a1.up<a2.up)&&(a1.down<a2.down);
}

bool cmp2(dot d1, dot d2){   //对玩具进行排序的方法
    return d1.x<d2.x;
}

int cross(int x1, int x2, int y1, int y2){  //求叉积
    return (x1*y2)-(x2*y1);
}
int main(){
    int n, m, x1, y1, x2, y2;
    while(scanf("%d", &n), n){
        scanf("%d%d%d%d%d", &m, &x1, &y1, &x2, &y2);
        for(int i = 0; i<n; i++){
            scanf("%d %d", &broad[i].up, &broad[i].down);
        }
        for(int i = 0; i<m; i++){
            scanf("%d%d", &node[i].x, &node[i].y);
        }
        sort(broad, broad+n, cmp1);
        sort(node, node+m, cmp2);
        int ans[maxn];
        int num[maxn];
        memset(ans, 0, sizeof(ans));
        memset(num, 0, sizeof(num));
        for(int i=0; i<m; i++){
            int flag = 0;
            int p;
            for(int j = 0; j<n; j++){
                if(cross(node[i].x-broad[j].down, node[i].y-y2, broad[j].up-broad[j].down, y1-y2)<=0){
                    flag = 1;
                    p = j;
                    break;
                }
            }
            if(flag == 1)
                ans[p]++;
            else
                ans[n]++;
        }
        for(int i = 0; i<=n; i++){
            if(ans[i]!=0){
                num[ans[i]]++;
            }
        }
        printf("Box\n");
        for(int i = 1; i<=m; i++){
            if(num[i]!=0){
                printf("%d: %d\n", i, num[i]);
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值