Red and Black
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 35903 | Accepted: 19444 |
Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
Sample Output
45 59 6
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int a,b,n,m;
char c[22][22];
int dfs(int a,int b)
{
if(c[a][b]=='#'||a>=m||b>=n||a<0||b<0)
return 0;
else
{
c[a][b]='#';
return 1+dfs(a,b+1)+dfs(a,b-1)+dfs(a-1,b)+dfs(a+1,b);
}
}
int main()
{
int i,j;
while(scanf("%d%d",&n,&m)&&n&&m)
{
for(i=0;i<m;i++)
{
getchar();
for(j=0;j<n;j++)
{
scanf("%c",&c[i][j]);
if(c[i][j]=='@')
{
a=i;b=j;
}
}
}
n=dfs(a,b);
printf("%d\n",n);
}
return 0;
}