hdoj 4709 Herding

Herding(链接)

Sample Input
   
   
1 4 -1.00 0.00 0.00 -3.00 2.00 0.00 2.00 2.00
 

Sample Output
   
   
2.00
 

题意:求给出的n个点可以构成最小的三角形面积
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;

//定义点
struct point
{
    double x;
    double y;
}a[110];

//利用叉积求三角形面积 S=1/2ab*sin(C)
double cross(point A,point B,point C)
{
    return fabs((B.x - A.x) * (C.y - A.y) - (C.x - A.x) * (B.y - A.y)) / 2;
}

int main()
{
    int i,j,k,m,n,t;
    scanf("%d",&t);
    while(t--)
    {
        double ans = 1e10;
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%lf%lf",&a[i].x,&a[i].y);
        }//暴力求解
        for(i=0;i<n;i++)
        {
            for(j=i+1;j<n;j++)
            {
                for(k=j+1;k<n;k++)
                {
                    if(cross(a[i],a[j],a[k])<1e-10)
                        continue;
                    else if(cross(a[i],a[j],a[k])<ans)
                        ans = cross(a[i],a[j],a[k]);
                }
            }
        }
        if(ans == 1e10)
            printf("Impossible\n");
        else
            printf("%.2lf\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值