11月27日 connect the city

本题我一直TLE,所以代码转载自https://www.cnblogs.com/13224ACMer/p/4639351.html


Description

In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  

Input

The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.

Output

For each case, output the least money you need to take, if it’s impossible, just output -1.

Sample Input

1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6

Sample Output

1

我自己的代码(感觉没问题,但是tle了,不知道是不是qsort的问题?)
#include<cstdio>
#include<algorithm>
#include<cstdlib>
using namespace std;
int rt[505], pr[505],Rank[505],ncase,sum;
struct edge{
	int a, b, le;
}eg[25005];
int n, m, k;
int cnt;
int find(int x)
{
	int tmp=x,root = x;
	while (pr[root] != root)
	{
		root = pr[root];
	}
	/*while (pr[tmp] != root)
	{
		rt[tmp] = root;
		tmp = pr[tmp];
	}*/
	return root;
}
void Union(int x,int y)
{
	int a = find(x);
	int b = find(y);
	pr[a] = b;
	/*else
	{
		pr[b] = a;
		if (Rank[a] == Rank[b])Rank[a]++;
	}*/
}
int cmp(const void* a, const void* b)
{
	return ((edge*)a)->le - ((edge*)b)->le;
}
void init(int n)
{
	for (int i = 0; i <= n; i++)
	{
		pr[i] = i;
		rt[i] = i;
	}
	sum = 0;
}
int main()
{
	scanf("%d", &ncase);
	for (int i = 0; i < ncase; i++)
	{
		int nedge = 0;
		scanf("%d%d%d", &n, &m, &k);
		int q = n;
		init(n);
		for (int j = 0; j < m; j++)
		{
			scanf("%d%d%d", &eg[j].a, &eg[j].b, &eg[j].le);
		}
		for (int j = 0; j < k; j++)
		{
			int num,rr;
			scanf("%d", &num);
			scanf("%d", &rr);
			for (int k = 0; k < num-1; k++)
			{
				int b;
				scanf("%d", &b);
				q -= (b-1);
				Union(b, rr);
			}
		}
		qsort(eg, m, sizeof(eg[0]), cmp);
		for (int j = 0; j < m && nedge!=q-1; j++)
		{
			int x = find(eg[j].a);
			int y = find(eg[j].b);
			if (x != y)
			{
				Union(eg[j].a, eg[j].b);
				sum += eg[j].le;
				nedge++;
			}
		}
		if (nedge < q - 1) printf("%d\n", -1);
		else printf("%d\n", sum);
	}
	return 0;
}
别人的代码
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
struct node{
   int u;
   int v;
   int w;
}que[100000];
int father[505];
bool cmp(struct node a,struct node b){
    return a.w<b.w;
}
void init(int n){
    for(int i=1;i<=n;i++)
    father[i]=i;
}
int find(int u){
    if(father[u]!=u)
    father[u]=find(father[u]);
    return father[u];
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
       int n,m,k;
       int edge=0,sum=0;
       scanf("%d%d%d",&n,&m,&k);
       init(n);
       for(int i=0;i<m;i++){
          scanf("%d%d%d",&que[i].u,&que[i].v,&que[i].w);
       }
       sort(que,que+m,cmp);
       for(int i=1;i<=k;i++){
           int cnt,root;
           scanf("%d%d",&cnt,&root);
           for(int j=1;j<cnt;j++){
              int x;
              scanf("%d",&x);
              int c1=find(x),c2=find(root);
              if(c1!=c2){
                  father[c1]=c2;
              }
           }
       }
      for(int i=1;i<=n;i++)
      if(father[i]==i)
      edge++;
      bool flag=false;
      for(int i=0;i<m;i++){
          int tx=find(que[i].u),ty=find(que[i].v);
          if(tx!=ty){
              father[tx]=ty;
              sum+=que[i].w;
              edge--;
          }
          if(edge==1){
            flag=true;
            break;
          }
 
      }
      if(flag)
      printf("%d\n",sum);
      else
      printf("-1\n");
 
    }
    return 0;
}
希望大神指导指导


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值