1008 - How many N

题目:

Problem Description

Find a minimal interger K which is merely comprised of N and can be divided by M.

For example,11 is the minimal number that and be divided by 11, and it is comprised of two '1's, and 111111 can be divided by 13 which is comprised of six '1's.

Input

On each line of input , there will be two positive integer, N and M. N is a digit number, M is no more than 10000.

Output

On each single line, output the number of N, if no such K, output zero.

Sample Input

1 5
1 11
1 13

Sample Output

0
2
6

先占个坑,等我搞懂原理回来补坑

ac代码

#include <stdio.h>
#include <stdlib.h>

int main()
{
    
    int n,m;
    
    while(scanf("%d%d",&n,&m)==2)
    {
        int num = n;
        int count = 1;

        while((num%m!=0)&&(count<=2*m))
        {

            num = 10 * (num % m) + n;
            count++;

        }
        if(count == 2*m+1)

            count=0;

        printf("%d\n",count);

    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值