由cuda9.1装回cuda9.0时的两个问题

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/qq_38290417/article/details/81327431

一开始想的是在保留cuda9.1的基础上,再安装cuda9.0
(1)报错:libcudnn-dev 依赖于cudnn7.0+cuda9.1,但是cudnn7.1+cuda9.0正要被安装。
之后无论什么操作机会都会被这一句给卡住。当时直接手动删了/usr/local下的cuda9.1,后来好像貌似是使用sudo apt-get -f remove libcudnn-dev给删除的。
(2)手动删了/var/cuda-repo-9-1。导致sudo apt-get update时会报错
这里写图片描述
这里写图片描述

我先试了将sourcelist中的源给还原,依然没有用。后来发现在/etc/apt/source.list.d这个文件下有一些其它的list,一查是放第三方源的,将有关cuda的全部删掉,恢复正常。
中途还有一些问题,据说使用runfile不会出现,而是用deb包会出现。最后使用的runfile安装的cuda,在执行代码时又会说:If using a binary install, upgrade your CuDNN library to match.即我的cudnn还是7.0的,重新下载一个覆盖进去即可。

展开阅读全文

没有更多推荐了,返回首页