多重背包 HDU 2844 Coins

多重背包可转化为01背包,首先将件数C二进制分解为多个件数的集合,这些件数可以组合成任意 小于等于C的数字,而且不会重复。
如7 7=111,可以分解为100,010,001,这三个数可以组合为任意小于等于7的数,而且每种组合都会得到不同的数。
13 13=1101,可以分解为0001,0010,0100,0110,前三个数可以组合成7以内的任意数,加上6就可以组合为任意大于6小于等于13的数,这样就能表示所有小于等于13的数。

题目

Whuacmers use coins.They have coins of value A1,A2,A3…An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
Output
For each test case output the answer on a single line.
Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

A[i]既代表体积又代表价值

#include <iostream>
#include <string.h>
#include <cmath>
#include <stdio.h>
#include <algorithm>
using namespace std;
typedef long long ll;
const ll INF=0x3f3f3f3f;
int dp[100005];
int coin[100005];
int main()
{
    int n,m;
    while(cin>>n>>m)
    {
        if(n==0&&m==0)
            break;
        int num=0;
        int A[105],B[105];
        for(int i=0;i<n;i++)
        {
            cin>>A[i];
        }
        for(int i=0;i<n;i++)
        {
            cin>>B[i];
        }
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
        {
            if(A[i]*B[i]>=m)   //如果A[i]*B[i]>m,说明该物品总体积大于背包体积,相当于有无穷件,因此转化为完全背包,这道题去掉会tle
            {
                for(int j=A[i];j<=m;j++)
                    dp[j]=max(dp[j],dp[j-A[i]]+A[i]);
            }
            else
            {
                for(int j=1;j<=B[i];j<<=1)           //二进制分解 
                {
                    for(int k=m;k>=j*A[i];k--)           
                        dp[k]=max(dp[k],dp[k-j*A[i]]+j*A[i]);
                    B[i]-=j;
                }
                if(B[i]>0)
                    for(int k=m;k>=B[i]*A[i];k--)
                        dp[k]=max(dp[k],dp[k-B[i]*A[i]]+B[i]*A[i]);
            }
        }
        int ans=0;
        for(int i=1;i<=m;i++)
            if(dp[i]==i)
                ans++;
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值