POJ 1125 Stockbroker Grapevine (Floyd)

题目

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their “Trusted sources” This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n) , followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a 1 means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100 . The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message “disjoint”. Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A <script type="math/tex" id="MathJax-Element-28">A</script> , if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

Source

Southern African 2001


题意

有几个人,输入他们与其他人通信所需要的时间,要求找到从哪一个人开始打电话直到打到最后一个人的时间最短,并输出最短时间。


分析

这是弗洛伊德求最短路算法,他可以算出任意两点之间的路。利用弗洛伊德算法求出从每个人出发到离他最远的那个人的通信时间,然后依次比较最远通信时间找出最小的,并且记录出发者的编号。首先令通信时间是无穷大,如果到最后通信时间还是无穷大,说明这条路没有联通,那就输出”disjoint”。


代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<queue>
#include<stack>
#include<vector>
#include<cmath>
#include<set>
#include<map>
#include<cstdlib>
#include<functional>
#include<climits>
#include<cctype>
#include<iomanip>
using namespace std;
typedef long long ll;
#define INF 0x3f3f3f3f
#define mod 1e9+7
#define clr(a,x) memset(a,x,sizeof(a))
const double eps = 1e-6;
int t;
int dp[1000][1000]; //用dp[i][j]表示从i号人到j号人的通信时间
void floyd()
{
    for(int k=1;k<=t;k++)
        for(int i=1;i<=t;i++)
            for(int j=1;j<=t;j++)
                dp[i][j]=min(dp[i][j],dp[i][k]+dp[k][j]);
}
int main()
{
    while(cin>>t,t)
    {
        int person,tim;
        clr(dp,INF);
        for(int i=1;i<=t;i++)
        {
            int n;
            cin>>n;
            dp[i][i]=0;  //初始化,自己到自己的通信时间为0
            while(n--)
            {
                cin>>person>>tim;
                dp[i][person]=tim;
            }
        }
        floyd();
        int m;
        int ans=INF,ans2;
        int flag=0;
        for(int i=1;i<=t;i++)
        {
            m=0;
            for(int j=1;j<=t;j++)
            {
                m=max(m,dp[i][j]);
            }
            if(ans>m)
            {
                ans=m;
                ans2=i;
            }
        }
        if(ans!=INF)
            cout<<ans2<<" "<<ans<<endl;
        else
            cout<<"disjoint"<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值