PAT-甲-1007 - Maximum Subsequence Sum

题目

1007 Maximum Subsequence Sum (25 分)
Given a sequence of K integers { N1, N​2​​ , …, N​K​​ }. A continuous subsequence is defined to be { N​i​​ , N​i+1​​ , …, N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

思路

对于给定的数组找最大子列,且需要给出最大子列和,第一个和最后一个元素。
最关键的是求最大子列,三个数字通过标记就能得到。

for(i=0;i<len;i++){
  sum += a[i];
  if(sum > max){
       max = sum ;
   }else if(sum <0){
      sum = 0;
   }
}

上面是一个简单的求最大子列和的代码。需要清楚一下几点

  • sum为负值时,肯定不是最大,如果都是负数,sum应该为0 。所以当sum<0时,需要将sum重置
  • 某一项为负时,该项未必不在最大子列中。只要该项不能导致sum为负,就可能处于子列中。如:8,-3,6
  • 上面的代码仅仅求出了sum,还需要记录begin和end两个数。
    • 对于begin,必定是一个非负数。如果存在最大子列且begin是负数,则去掉负数,sum会更大;若都是负数,则需单独考虑。begin可以为0。题中要求是去index最小的,则begin越小越好。
    • 对于end, 必须是一个正数。若为负数,则去掉sum更大,不正确。若为0,题中要求是index最小的,则也应该舍去。子列中每加入一个,更新一下end即可。

最后在输出时,需要考虑以下几种情况

  • 数组内都为负数,按体重要求输出即可
  • 存在最大子列,且sum>0,常规情况,输出即可
  • 存在最大子列,且sum=0。该情况对应case5,类似于 -2,0,0,-5。需要输出0 0 0。该情况的出现是因为将max设为0的原因。若数组都为整数,将max设为-1,则不需要考虑该种情况。
#include <stdio.h>
int main(){
  int  k ,i  ,lb=0,le=0,lsum =-1,b=0,sum=0,flag=1;
  if(1 != scanf("%d",&k))
     return - 2;
  int a[k]={0};
  for(i=0;i<k;i++){
    if(1 != scanf("%d",&a[i]))
      return -2;
  }
  for(i=0;i<k;i++){
    sum += a[i];
    if( a[i] >= 0 && sum == a[i]){  // 确定begin 
        b = i;
        flag = 0 ;  //进行标记,排除全为负数的情况
    }    
    if(sum>lsum ){ // update
      lsum = sum ;
      le = i;
      lb = b; // begin的更新只能放在此处,
    }else if(sum <0){
      sum = 0;
    }
  }
  if(flag){
    printf("%d %d %d",0,a[0],a[k-1]);
  }else {
    printf("%d %d %d",lsum,a[lb],a[le]);
  }
}

trick

  • printf("%d",0);
  • scanf("%d" ,&a[0])
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值