1133. Splitting A Linked List (25)

1133. Splitting A Linked List (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=1000). The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer in [-105, 105], and Next is the position of the next node. It is guaranteed that the list is not empty.

Output Specification:

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218
Sample Output:
33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1
大意:给一条单向链表,按链表顺序先输出data<0的节点,再输出data 小于等于k的节点,最后输出大于k的节点

思路:读入链表后遍历一次,将<0 <=k  >k  分别存放,最后依次输出

注意:1.输入可能有无效节点,所以一定要遍历一次过滤

           2.next是根据重新排列以后的顺序来定的

           3.用数组模拟链表会比较方便

           4.输出要固定5个数字,所以用printf会比较方便

           5.最后一个-1 要和第4条区别开

           6.考虑极端情况,例如没有<0 的时候  或者只有 <0 的时候

代码:

#include <iostream>
#include <stdlib.h>
#include <iomanip> 
#include <string.h>
using namespace std;
int nxt[100000];
int list[100000];
int minlist[100000]; int j = 0;
int midlist[100000]; int p = 0;
int maxlist[100000]; int q = 0;
int main()
{
	int add, k, num;
	cin >> add >> num >> k;
	int a, b, c;
	memset(nxt, -1, sizeof(int) * 100000);
	memset(list, -1, sizeof(int) * 100000);
	for (int i = 0; i < num; i++)
	{
		cin >> a >> b >> c;
		list[a] = b;
		nxt[a] = c;
	}
	a = add; 
	while (a!=-1)
	{
		if (list[a] < 0) minlist[j++] = a;
		else if (list[a] >= 0 && list[a] <= k) midlist[p++] = a;
		else maxlist[q++] = a;
		a = nxt[a];
	}
	int judge = 0;
	for (int i = 0; i < j; i++) {
		if (judge) cout << setw(5) << setfill('0') << minlist[i] << endl;
		cout << setw(5) << setfill('0') << minlist[i] << " " << list[minlist[i]] << " ";
		judge = 1;
	}
	for (int i = 0; i < p; i++) {
		if (judge) cout << setw(5) << setfill('0') << midlist[i] << endl;
		cout << setw(5) << setfill('0') << midlist[i] << " " << list[midlist[i]] << " ";
		judge = 1;
	}
	for (int i = 0; i < q; i++) {
		if (judge) cout << setw(5) << setfill('0') << maxlist[i] << endl;
		cout << setw(5) << setfill('0') << maxlist[i] << " " << list[maxlist[i]] << " ";
		judge = 1;
	}
	cout << -1 << endl;
}

上面的代码有很多可以优化的地方,比如用print可以看起来精简很多,最后三个的输出可以用一个for来写,开头申请三个list太占空间用vector可以完美解决

感言:这题似乎是第二次做,然后还是折腾了半天,各种莫名奇妙的bug,还有各种考虑不周到。不过开心的是,这次的写的代码比上次好看多了 o(* ̄▽ ̄*)ブ

测试点:第一个测试点是样例

              第二个测试点(估计)是复杂情况的样例,三种情况都输出

              第三个测试点第四个测试点没有<0 的数据

              第五个测试点(估计)有无效节点,需要过滤





  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值