Subsequence
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 15788 | Accepted: 6661 |
Description
A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2 10 15 5 1 3 5 10 7 4 9 2 8 5 11 1 2 3 4 5
Sample Output
2 3
题意:给定长度为n的数列整数A0,A1,A2……An-1以及整数S。求出总和不小于S的连续子序列的长度的最小值。如果解不存在,则输出0。
#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
int T;
int a[100010];
scanf("%d",&T);
while(T--)
{
int ans=200000;
int N,S;
scanf("%d%d",&N,&S);
for(int i=1;i<=N;i++)
{
int t;
scanf("%d",&t);
if(i==1)
a[i]=t;
else
a[i]=a[i-1]+t;
}
a[0]=0;
for(int i=1;i<=N;i++)
{
int left=i,right=N,mid;
while(left<=right)
{
mid=(left+right)/2;
if(a[mid]-a[i-1]>=S)
{
if(ans>mid-i+1)
ans=mid-i+1;
right=mid-1;
}
else
{
left=mid+1;
}
}
}
if(ans==200000)
printf("0\n");
else
printf("%d\n",ans);
}
return 0;
}