HDU5748-Bellovin【最长上升子序列的变形】


                     点击打开链接



Sample Input
  
  
3 1 10 5 5 4 3 2 1 3 1 3 5
 

Sample Output
  
  
1 1 1 1 1 1 1 2 3

给一个序列,求出每个位置结尾的最长上升子序列;然后找一个字典序最小的这个函数值相同的子序列;


 
#include <cstdio>  
#include <cstring>
#include<algorithm>  
using namespace std;  
#define INF	0x3f3f3f3f  
int dp[100010];  
  
int main()  
{  
    int t;  
    scanf("%d",&t);  
    while (t--)  
    {  
        int n,a;  
        scanf("%d",&n);  
        for(int i=0; i<=n; i++)  
            dp[i]=INF;  
        for (int i=0; i<n; i++)  
        {  
            scanf("%d",&a);  
            int pos=lower_bound(dp,dp+n,a)-dp;	  
            printf (i==0?"%d":" %d",pos+1);  
            dp[pos]=a;  
            //printf("\ndp[%d]==%d\n",pos,dp[pos]);
        }  
        printf("\n");  
    }  
    return 0;  
}  












评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值