Sample Input
3 1 10 5 5 4 3 2 1 3 1 3 5
Sample Output
1 1 1 1 1 1 1 2 3
给一个序列,求出每个位置结尾的最长上升子序列;然后找一个字典序最小的这个函数值相同的子序列;
#include <cstdio>
#include <cstring>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
int dp[100010];
int main()
{
int t;
scanf("%d",&t);
while (t--)
{
int n,a;
scanf("%d",&n);
for(int i=0; i<=n; i++)
dp[i]=INF;
for (int i=0; i<n; i++)
{
scanf("%d",&a);
int pos=lower_bound(dp,dp+n,a)-dp;
printf (i==0?"%d":" %d",pos+1);
dp[pos]=a;
//printf("\ndp[%d]==%d\n",pos,dp[pos]);
}
printf("\n");
}
return 0;
}