本题要求将输入的任意3个整数从小到大输出。
输入格式:
输入在一行中给出3个整数,其间以空格分隔。
输出格式:
在一行中将3个整数从小到大输出,其间以“->”相连。
输入样例:
4 2 8
输出样例:
2->4->8
代码如下:
#include <stdio.h>
int main() {
int a,b,c;
int t=0;
scanf("%d %d %d",&a,&b,&c);
if(a>b) {
t=b;
b=a;
a=t;
}
if(b>c) {
t=c;
c=b;
b=t;
}
if(a>b) {
t=b;
b=a;
a=t;
}
printf("%d->%d->%d",a,b,c);
return 0;
}