HDU 5119 Happy Matt Friends(动态规划)【状压基础类模板】

Matt has N friends. They are playing a game together. 

Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins. 

Matt wants to know the number of ways to win.
Input
The first line contains only one integer T , which indicates the number of test cases. 

For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 10  6). 

In the second line, there are N integers ki (0 ≤ k  i ≤ 10  6), indicating the i-th friend’s magic number.
Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.
Sample Input
2
3 2
1 2 3
3 3
1 2 3
Sample Output
Case #1: 4
Case #2: 2


        
  
Hint
In the first sample, Matt can win by selecting:
friend with number 1 and friend with number 2. The xor sum is 3.
friend with number 1 and friend with number 3. The xor sum is 2.
friend with number 2. The xor sum is 2.
friend with number 3. The xor sum is 3. Hence, the answer is 4.

 【题意】 题意说有N个朋友,每个人都有一个魔法数字,现在要从这N个人中选出一些人,使得他们所拥有的的数字的亦或值大于M,求所有的方案数。

 一开始还以为是个数学题,但是却出现在动态规划的专题了,想了好久还是不会,看了大牛们的博客,才知道这题是暴力解。

 因为这题给的数据范围是40个数,每个数小于10^6,所以这些数的最大亦或值也就2^20,所以直接暴力解,然后在大于给的M的范围内求和即为所求。

 不得不说这方法很厉害,能想出这方法的人也一定是大牛中的大牛,佩服。

 【AC代码】

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int N=50;
int m,n;
int a[N];
__int64 dp[2][(1<<20)+5];//这儿里面一定要加括号,不然会爆内存

int main()
{
    int t,cnt=0;
    scanf("%d",&t);
    while(t--){
    while(~scanf("%d%d",&m,&n))
    {
        for(int i=1;i<=m;++i)
            scanf("%d",&a[i]);
        sort(a,a+m);
        memset(dp,0,sizeof(dp));
        dp[0][0]=1;
        for(int i=1;i<=m;i++)
        {
            for(int j=0;j<(1<<20);j++)//每个数都有两种状态,取或者不取
                dp[i%2][j]=dp[(i-1)%2][j]+dp[(i-1)%2][j^a[i]];
        }
        __int64 ans=0;//注意类型   会爆int
        for(int i=n;i<(1<<20);++i)
        {
            ans+=dp[m%2][i];
        }
        printf("Case #%d: %I64d\n",++cnt,ans);
    }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值