-----背包 DP hdu 5119- Happy Matt Friends

Matt has N friends. They are playing a game together.

Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins.

Matt wants to know the number of ways to win.
Input
The first line contains only one integer T , which indicates the number of test cases.

For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 10 6).

In the second line, there are N integers ki (0 ≤ k i ≤ 10 6), indicating the i-th friend’s magic number.
Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.
Sample Input
2
3 2
1 2 3
3 3
1 2 3
Sample Output
Case #1: 4
Case #2: 2

Hint
In the first sample, Matt can win by selecting:
friend with number 1 and friend with number 2. The xor sum is 3.
friend with number 1 and friend with number 3. The xor sum is 2.
friend with number 2. The xor sum is 2.
friend with number 3. The xor sum is 3. Hence, the answer is 4.


题意:
给你n个数,你可以从里面任意挑数异或,要求亦或后的结果大于等于m,问你可以有多少种异或的方案(・∀・(・∀・(・∀・*)
思路:
前i个数异或后的结果为j的方案数=前i-1个数异或后的结果为j的方案数+前i个数异或后的结果为j^a[i]的方案数;
为什么是j^a[i]呢,因为j^a[i]^a[i]=j^(a[i]^a[i])=j^0=j;前i-1个数异或后的结果已经是j^a[i]了,因为选的是前i个数异或,所以还有a[i]没被用,这个时候,那些异或后结果是j^a[i]的方案在异或上a[i],结果就是j

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>
#define maxx 1<<20
using namespace std;

typedef long long LL;
int a[45];
LL dp[45][maxx];///dp[i][j]代表从第1个数到第i个数,亦或后结果为j的方案的数目
///任何数和0异或后的·结果依然是本身
int main()
{
    int t,n,m;
    scanf("%d",&t);
    for(int cas=1; cas<=t; cas++)
    {
        memset(dp,0,sizeof(dp));
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
            scanf("%d",&a[i]);
        dp[0][0]=1;
        for(int i=1; i<=n; i++)
            for(int j=0; j<maxx; j++)
                dp[i][j]=dp[i-1][j]+dp[i-1][j^a[i]];
            LL sum=0;
            for(int k=m;k<maxx;k++)
                sum+=dp[n][k];
                printf("Case #%d: ",cas);
            printf("%lld\n",sum);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值