POJ 2677 Tour(动态规划+双调欧几里得旅行商算法)【模板】

John Doe, a skilled pilot, enjoys traveling. While on vacation, he rents a small plane and starts visiting beautiful places. To save money, John must determine the shortest closed tour that connects his destinations. Each destination is represented by a point in the plane pi = < xi,yi >. John uses the following strategy: he starts from the leftmost point, then he goes strictly left to right to the rightmost point, and then he goes strictly right back to the starting point. It is known that the points have distinct x-coordinates. 
Write a program that, given a set of n points in the plane, computes the shortest closed tour that connects the points according to John's strategy.
Input
The program input is from a text file. Each data set in the file stands for a particular set of points. For each set of points the data set contains the number of points, and the point coordinates in ascending order of the x coordinate. White spaces can occur freely in input. The input data are correct.
Output
For each set of data, your program should print the result to the standard output from the beginning of a line. The tour length, a floating-point number with two fractional digits, represents the result. An input/output sample is in the table below. Here there are two data sets. The first one contains 3 points specified by their x and y coordinates. The second point, for example, has the x coordinate 2, and the y coordinate 3. The result for each data set is the tour length, (6.47 for the first data set in the given example).
Sample Input
3
1 1
2 3
3 1
4
1 1
2 3
3 1
4 2
Sample Output
6.47
7.89
 【题解】 题意为一个飞行员,想去一些美丽的地方,这些地方在一张二维地图上,现在他要从最左边的城市出发,向右旅行,到达最右边后再回来,现在要求计算出他要走的最短距离。


  这是个经典的双调欧几里得旅行商算法题,关于它的知识请参考:http://http://blog.sina.com.cn/s/blog_41630e7e0100dp4o.html

http://http://www.cnblogs.com/shuaiwhu/archive/2012/05/13/2497355.html

http://http://blog.sina.com.cn/s/blog_51cea4040100gkcq.html

知道了这个原理,解这道题就很简单了。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<math.h>
using namespace std;
const int N=1000;
const int INF=1e9+7;
int n;
double dp[N][N];

struct point
{
    double x,y;
}node[N];

bool cmp(point a,point b)//排序函数
{
    return a.x<b.x;
}

double dis(int i,int j)//距离函数
{
    return sqrt((node[i].x-node[j].x)*(node[i].x-node[j].x)+(node[i].y-node[j].y)*(node[i].y-node[j].y));
}

int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
            scanf("%lf%lf",&node[i].x,&node[i].y);
        sort(node+1,node+n+1,cmp);//从小到大排序
        dp[1][2]=dis(1,2);
        for(int i=3;i<=n;i++)
        {
            for(int j=1;j<=i-2;++j)
            {
                dp[j][i]=dp[j][i-1]+dis(i-1,i);
            }
            dp[i-1][i]=INF;
            for(int k=1;k<=i-2;++k)
            {
                double temp = dis(k,i)+dp[k][i-1];
                if(temp<dp[i-1][i])
                    dp[i-1][i]=temp;
            }
        }
        dp[n][n]=dp[n-1][n]+dis(n-1,n);
        printf("%.2f\n",dp[n][n]);
    }
    return 0;
}



  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值