动态规划——Tour

John Doe, a skilled pilot, enjoys traveling. While on vacation, he rents a small plane and starts visiting beautiful places. To save money, John must determine the shortest closed tour that connects his destinations. Each destination is represented by a point in the plane pi = < xi,yi >. John uses the following strategy: he starts from the leftmost point, then he goes strictly left to right to the rightmost point, and then he goes strictly right back to the starting point. It is known that the points have distinct x-coordinates. Write a program that, given a set of n points in the plane, computes the shortest closed tour that connects the points according to John's strategy.
Input

The program input is from a text file. Each data set in the file stands for a particular set of points. For each set of points the data set contains the number of points, and the point coordinates in ascending order of the x coordinate. White spaces can occur freely in input. The input data are correct.
Output

For each set of data, your program should print the result to the standard output from the beginning of a line. The tour length, a floating-point number with two fractional digits, represents the result. An input/output sample is in the table below. Here there are two data sets. The first one contains 3 points specified by their x and y coordinates. The second point, for example, has the x coordinate 2, and the y coordinate 3. The result for each data set is the tour length, (6.47 for the first data set in the given example).
Sample Input

3
1 1
2 3
3 1
4
1 1
2 3
3 1
4 2
Sample Output

6.47
7.89



题意:按从左到右的顺序给出n个点,求从最左边到最右边再到最左边的最短距离(欧几里德距离)是多少。每个点只能走一次(除了最左边和最右边的点以外)。

思路:

这题在紫书(《算法竞赛入门经典(第2版)》)上作为例题讲过,复杂度是O(n2)。

因为从左到右再回来不方便思考,于是变成两个人同时从最左点出发,走不同的路到达最右点。

为了方便后续的转移,设置dp[i][j]表示1~max(i, j)都走过,且两人的位置分别是i和j时,此时还需要走的距离。

则可以明白dp[i][j]==dp[j][i],所以不妨规定i>j。

那么想走到下一步有两种走法

1.i走到i+1,则有dp[i+1][j]=min(dp[i+1][j], dp[i][j]+dis(i+1, i)) 

2.j走到i+1,则有dp[i+1][i]=min(dp[i+1][i], dp[i][j]+dis(i+1, j))


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#define INF 0x3f3f3f3f
using namespace std;
const int maxn=1010;
struct node
{
    double x, y;
}point[maxn];
double dis(int a, int b)     //求欧几里德距离
{
    double dx=point[a].x-point[b].x;
    double dy=point[a].y-point[b].y;
    return sqrt(dx*dx+dy*dy);
}
int n;
double dp[maxn][maxn];
int main()
{
    while(~scanf("%d", &n))
    {
        for(int i=0; i<n; i++)
            scanf("%lf%lf", &point[i].x, &point[i].y);
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
                dp[i][j]=INF;
        dp[0][0]=0;
        dp[1][0]=dis(1,0);
        for(int i=1; i<n; i++)
            for(int j=0; j<i; j++)
            {
                dp[i+1][j]=min(dp[i+1][j], dp[i][j]+dis(i, i+1));
                dp[i+1][i]=min(dp[i+1][i], dp[i][j]+dis(i+1, j));
            }
        double ans=INF*1.0;
        for(int i=0; i<n; i++)
            ans=min(ans, dp[n-1][i]+dis(n-1, i));     //枚举每个求最小
        printf("%.2f\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值