HDU 2955 Robberies(变形背包)

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university. 


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible. 


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set. 

Notes and Constraints 
0 < T <= 100 
0.0 <= P <= 1.0 
0 < N <= 100 
0 < Mj <= 100 
0.0 <= Pj <= 1.0 
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
Sample Output
2
4
6

 【题解】这道题做的真是一波三折啊,各种酸甜苦辣都尝遍了(RE, TLE, WA, CE, AC),不过在我的努力下终于把BUG都找出来了,心情爽歪歪~~~

 这道题有个技巧,就是原本按照背包的思想dp数组的下标应该是概率,但是下标不可能是小数,所以我们就可以把不同价值和对应的概率保存在dp数组中,这样最后只需要价值大的往价值小的遍历一遍,找到第一个概率小于等于被抓概率的dp[i],这个下标i 就是对应的最大价值。

  这么说你应该明白了吧,,就是思维稍微转一下,嘿嘿~

 【AC代码】

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int N=5000;
int a[N];
double dp[20000],b[N];

int main()
{
    int n,t;
    double m;
    scanf("%d",&t);
    while(t--)
    {
        int sum=0;
        scanf("%lf%d",&m,&n);
        for(int i=1;i<=n;++i)
        {
            scanf("%d%lf",&a[i],&b[i]);
            sum+=a[i];//求总价值
        }
        memset(dp,0,sizeof(dp));
        dp[0]=1.0;                  //这个很重要
        for(int i=1;i<=n;++i)
        {
            for(int j=sum;j>=a[i];--j)//从总价值往小遍历
                dp[j]=max(dp[j],dp[j-a[i]]*(1-b[i]));//概率相乘
        }

        for(int i=sum;i>=0;--i)//遍历一遍找到不会被抓的
        {
            if(dp[i]>=(1-m))
            {
                printf("%d\n",i);
                break;
            }
        }
    }
    return 0;
}

 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值