POJ 3071 Football (概率DP)

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After nrounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input
2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1
Sample Output
2
Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins) P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.


 【题解】

题出的相当好,充分体现了位运算的灵活运用。

题意就是有n只球队,编号1~n,现在要进行两两pk,第一支队和第二支队pk,第三支队和第四支队pk,依次类推,输的划掉,每轮都是这种规则,求最后获胜几率最大的是哪只球队。

定义数组dp[i][j],表示第i轮第j支队获胜的概率,那么递推式就是:dp[i][j]+=sigma{dp[i-1][j]*dp[i-1][k]*p[j][k]},p表示j队打败k队的概率;

这里就有个涉及确定相邻对手的问题,因为每次都要淘汰一半队伍,所以对战顺序是个问题,不过,位运算刚好可以解决这个问题:


解释一下,刚开始有四支队伍,编号0~3,那么第一轮完了一二支队伍里面肯定会胜出一队,三四队也会有一队胜出,而胜出的队也会被重新编号0,1,那么很显然,0/1队胜出的一定是要和2/3队胜出的打,那这个过程就可以用位运算来解决,不论0队胜还是1队胜出,二进制右移一位后都会变成0,2/3队胜出的右移后一定是1,这就相当于给它们重新编号0,1,一样,所以每次给第一个队右移一位后与1进行亦或运算,如果和第二支队右移后的值相同,说明他们就是相邻的,这样选对手问题就解决了。

剩下的部分看代码:

【AC代码】

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<math.h>
using namespace std;
const int N=8;
double dp[N][130],p[130][130];
int m;

int main()
{
    while(~scanf("%d",&m)&&m!=-1)
    {
        int x=pow(2,m);
        for(int i=1;i<=x;++i)
            for(int j=1;j<=x;++j)
            scanf("%lf",&p[i][j]);
        memset(dp,0,sizeof dp);
        for(int i=1;i<=x;++i)
            dp[0][i]=1.0; //没开始前所有人的获胜概率都为1
        for(int i=1;i<=m;++i)//第i轮比赛
            for(int j=1;j<=x;++j) //第j个人获胜的概率
                for(int k=1;k<=x;++k) //第j个人打败第k个人的概率
                {
                    if( (((j-1)>>(i-1))^1)==((k-1)>>(i-1)) ) //这一步真的是太妙了 , 一切都在i的掌控中
                    { //  
                        dp[i][j]+=dp[i-1][j]*dp[i-1][k]*p[j][k]; //概率相加  至于为什么  看题后样例解释
                    }
                }
        double maxn=dp[m][1];
        int index=1;
        for(int i=2;i<=x;++i)
            if(dp[m][i]>maxn){
                maxn=dp[m][i];
                index=i;
            }
        printf("%d\n",index);
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值