HDU 4405 Aeroplane chess (概率-期望DP)【模板】

Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N. 

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid. 

Please help Hzz calculate the expected dice throwing times to finish the game. 
Input
There are multiple test cases. 
Each test case contains several lines. 
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000). 
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).   
The input end with N=0, M=0. 
Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point. 
Sample Input
2 0
8 3
2 4
4 5
7 8
0 0
Sample Output
1.1667
2.3441

 【题解】

 大致题意:

 一条路,有0~n 总共n+1个点,起点在0处,每次先摇骰子,骰子有6个面,1,2,3,4,5,6,根据摇出的点数前进响应的步数,现在告诉你在路上有m个传送阵(只能往后传),从x传到y处,传送阵不消耗骰子,求走到终点需要摇骰子的次数期望值。

 分析:设dp[i]为i到i点的需要摇骰子的次数期望值,那么就有两种情况,i点有传送阵和没有传送阵;

 有传送阵的话就是dp[i] = dp[pre[i]];

 没有传送阵的话   dp[i]+= dp[i+j]/6.0,dp[i]+=1;(1<=j<=6)

 注意要从后往前递推,这样想:从i+j点到达i点的概率是1/6,每次先遍历i,里面再遍历j,这样最后dp[0]就是到达起点的次数期望值。

 

【AC代码】

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int N=100010;
int m,n;
double dp[N];
int pre[N];

struct edge
{
    int x,y;
}e[1003];

bool cmp(edge a,edge b)
{
    return a.x<b.x;
}

int main()
{
    int x,y;
    while(~scanf("%d%d",&m,&n),m+n)
    {
        memset(pre,-1,sizeof pre);
        for(int i=0;i<n;++i){
            scanf("%d%d",&x,&y);
            pre[x]=y;
        }
        memset(dp,0,sizeof dp);
        dp[m]=0;
        for(int i=m-1;i>=0;--i)//从后往前递推
        {
            if(pre[i]!=-1){//如果i点没有通道  那么直接从后面prep[i]移动到i点来
                dp[i]=dp[pre[i]]; //表示从y移动到x来  x<y
            }
            else//没有通道的话  继续递推
            {
                for(int j=1;j<=6;++j){
                    if(i+j>=m) break; //终点以后的就不管了
                dp[i]+=dp[i+j]/6.0; //这儿可以反面想  要从后面不同的点到达i点的概率都是1/6,所以遍历一遍i后面的点到达i的概率
                }
                dp[i]+=1.0;//花费一次摇骰子机会
            }
        }
        printf("%.4f\n",dp[0]);
    }
    return 0;
}


 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值