HDU 1217 Arbitrage

Arbitrage

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.

Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0
Sample Output
Case 1: Yes
Case 2: No


题目网址:http://acm.hdu.edu.cn/showproblem.php?pid=1217

分析

题意:用不用钱之间兑换的差价可以赢取利益,比如1美元买0.5英镑,0.5英镑去买来5法郎,5法郎去买来1.05美元,从而盈利0.05美元,给出各种钱币的兑换比例,求出能否去获取盈利

思路:显然,将一种钱币兑换成别的钱币最终再兑换回来,就相当于将各个兑换比例相乘,最短路问题,将各种兑换的比例存入二维数组,然后用各种面值的去比较,最后将乘积大的兑换比例存入maps[i][i],最后遍历maps[i][i],只要用一个值大于1,就说明能够从中谋利

代码
#include <bits/stdc++.h>
using namespace std;
double maps[33][33];
int main()
{
    int n,Case=0;
    while(~scanf("%d",&n)&&n)
    {
        Case++;
        string s[33];
        for(int i=0; i<n; i++)
            cin>>s[i];
        int m;
        scanf("%d",&m);
        memset(maps, 0, sizeof(maps));///存的值清零
        for(int i=0; i<m; i++)
        {
            string st,en;
            double val;
            int staa=-1,endd=-1;
            cin>>st>>val>>en;
            for(int j=0; j<n; j++)
            {
                if(st==s[j])staa=j;///将不同钱币的名称转换为数字
                if(en==s[j])endd=j;
                if(staa!=-1&&endd!=-1)break;
            }
            maps[staa][endd]=val;///将兑换比例存入数组
        }
        for(int i=0; i<n; i++)///Floyd更新数组的值
        {
            for(int j=0; j<n; j++)
            {
                for(int k=0; k<n; k++)
                {
                    if(maps[j][k]<maps[j][i]*maps[i][k])///如果乘积比原本的大,说明能兑换的更多
                        maps[j][k]=maps[j][i]*maps[i][k];
                }
            }
        }
        for(int i=0; i<n; i++)
        {
            if(maps[i][i]>1)
            {
                printf("Case %d: Yes\n",Case);///判断有没有能够盈利的兑换方法
                break;
            }
            else if(i==n-1)printf("Case %d: No\n",Case);
        }
    }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值