poj-1751-Highways-最小生成树

Highways

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of ith town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.

Sample Input

9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6

3 7

4 9

5 7

8 3


题意:就是最小生成树。有N个点,要找到一条经过所有点的路径,且使路径长度最短。在开始时,已经有m条路是通的,不用修建的。

把这部分的权值为0就行了。

#include<iostream>
#include<cmath>
#include<cstdio>
using namespace std;
#define MAXV 1005
#define INF 0x3f3f3f3f
int Tu[MAXV][MAXV];
int bj[MAXV];//标记这个点有没有访问过
int N,M,Count;
int minn;
struct Dao
{
    int x;
    int y;
}dao[1005];
int dis(int i,int j)
{
    return (dao[i].x-dao[j].x)*(dao[i].x-dao[j].x)+(dao[i].y-dao[j].y)*(dao[i].y-dao[j].y);
}
void prim()
{
    int lowcost[MAXV];///保存权值,用来查找最小。已经查过使值等于0
    int closet[MAXV];///保存路。
    int i,j,k;
    for(i=1;i<=N;i++)///初始化距离起点的值lowcost
    {
        lowcost[i]=Tu[1][i];//起点为1
        bj[i]=0;
        closet[i]=1;//保存起点
    }
    bj[1]=1;
    k=1;
    for(i=2;i<=N;i++)///遍历除起点外所有的点
    {
        int minds=INF;
        for(j=1;j<=N;j++)///找到距离最近的值
        {
            if(bj[j]==0&&lowcost[j]<minds)///找到要新加入点k
            {
                minds=lowcost[j];
                k=j;
            }
        }
        if(minds==INF)///如果没有最近的值则返回
        {
            return;
        }
        Count++;///如果点数不够,说明没有形成最小生成树,即路不通
        bj[k]=1;
        lowcost[k]=0;///已经查过使值等于0
        minn+=minds;///路畅通工程再续程和
        if(Tu[closet[k]][k]!=0)
            printf("%d %d\n",closet[k],k);
        //printf("满足条件的边(%d,%d),权值为%d\n",closet[k],k,minds);
        for(j=1;j<=N;j++)///更新lowcost
        {
            if(bj[j]==0&&(Tu[k][j]<lowcost[j]))///在没查找过的值和相同的点之外。根据新加入的k,查找是否有距离更近的值。
            {
                lowcost[j]=Tu[k][j];
                closet[j]=k;///将点保存
            }
        }
    }
}
int main()
{
    int a,b;
    Count=0;minn=0;
    scanf("%d",&N);
    //init();
    for(int i=1;i<=N;i++)
    {
        scanf("%d%d",&dao[i].x,&dao[i].y);
    }
    for(int i=1;i<=N;i++)
        for(int j=1;j<=N;j++)
    {
        Tu[i][j]=Tu[j][i]=dis(i,j);
    }
    scanf("%d",&M);
    while(M--)
    {
        scanf("%d %d",&a,&b);
        Tu[a][b]=Tu[b][a]=0;
    }
    prim();
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值